This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 749586

Summary: [webadmin] All dialogs do not open after a log-off and re-login
Product: [Community] oVirt Reporter: Danny Rankevich <drankevi>
Component: ovirt-engine-webadminAssignee: Einav Cohen <ecohen>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: ecohen, iheim, mgoldboi, rvaknin, vszocs, ykaul
Target Milestone: ---   
Target Release: 3.1   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-09 04:00:11 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Danny Rankevich 2011-10-27 11:39:27 EDT
Description of problem:
When a log-off event occurs, either through a session expiration event or a manual log-off, the table actions stop working.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Always.

Steps to Reproduce:
1. Login to the webadmin.
2. Logoff from the webadmin (by clicking sign-out)
3. Login to the webadmin again.
4. None of the action buttons open dialogs.
  
Actual results:
When you click on an action, nothing happens.

Expected results:
A dialog should be opened.

Additional info:
I think this is cause by the fact that the log-off does not delete the CommonModel instance, and we still use the same instance.
I am sure there is a specific fix for this issues, however, INHO, the solution should be to refresh the entire webadmin after a logoff.
This will fix any additional problems that might be discovered over time.
Comment 1 Danny Rankevich 2011-10-27 12:21:35 EDT
*** Bug 744714 has been marked as a duplicate of this bug. ***
Comment 2 Danny Rankevich 2011-10-27 12:26:10 EDT
*** Bug 748794 has been marked as a duplicate of this bug. ***
Comment 4 vszocs 2011-11-04 05:51:49 EDT
CommonModel instance is created upon each user login via CommonModelManager, and cleared (nullified) upon each user logout. This is because CommonModel initializes its child list models right within its constructor, and at that time CommonModel expects the user to be logged-in already. Upon each re-login, model providers are notified that CommonModel instance has changed via CommonModelChangeEvent.

The problem with action buttons is following: UiCommandButtonDefinition references UICommand's directly.

After re-login, this is what happens: CommonModel reference changes -> related main list model reference changes -> UICommand reference changes.

Action button still references original UICommand, its Execute() is called properly, but model provider for related main list model is listening/attached to new (changed) main list model reference.
Comment 8 Itamar Heim 2012-08-09 04:00:11 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/