This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 749661

Summary: repoclosure failure on 16.TC3 DVD - PackageKit-zif-0.6.19-3.fc16 requires zif >= 0:0.2.5
Product: [Fedora] Fedora Reporter: Andre Robatino <robatino>
Component: distributionAssignee: Dennis Gilmore <dennis>
Status: CLOSED ERRATA QA Contact: Bill Nottingham <notting>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: awilliam, dennis, kevin, rhughes, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: AcceptedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-29 13:10:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 713568    

Description Andre Robatino 2011-10-27 16:10:08 EDT
Description of problem:

The 16.TC3 DVDs contain PackageKit-zif-0.6.19-3.fc16 and zif-0.2.3-1.fc16.

i386:

package: PackageKit-zif-0.6.19-3.fc16.i686 from myrepo
  unresolved deps: 
     zif >= 0:0.2.5

x86_64:

package: PackageKit-zif-0.6.19-3.fc16.x86_64 from myrepo
  unresolved deps: 
     zif >= 0:0.2.5

Version-Release number of selected component (if applicable):
16.TC3 DVD (i386 and x86_64)
Comment 1 Bill Nottingham 2011-10-27 16:19:49 EDT
We should either not be using greedy dependency solving when composing the DVD, or should be explicitly excluding this.
Comment 2 Bill Nottingham 2011-10-27 16:28:29 EDT
Also, we could push the zif update in:
https://admin.fedoraproject.org/updates/FEDORA-2011-13709
to final.
Comment 3 Adam Williamson 2011-10-27 17:01:59 EDT
I think some bit of KDE introduced a dependency on zif since the builds that went into TC2, and that got picked up by the mass glibc rebuild.

CCing KK for info. Kevin, what bit of KDE grew this zif dependency? Is it necessary?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Kevin Kofler 2011-10-27 17:38:01 EDT
The KDE software does not require zif.

What does happen is:
* Apper (and KPackageKit before it) requires PackageKit.
* PackageKit requires a PackageKit backend.
* Both PackageKit-yum and PackageKit-zif satisfy the dependency.
* The DVD compose drags both in, because by default all possible providers of a dependency get dragged in into the compose, unless they get explicitly excluded.

I think PackageKit-zif probably needs to be explicitly blacklisted in the DVD kickstart (and java-1.7.0-openjdk too, for that matter).
Comment 5 Kevin Kofler 2011-10-27 17:40:23 EDT
That said, IMHO the update which fixes the broken dependency should get pulled into the GA repository, otherwise repoclosure will complain about broken dependencies in Everything forever. (Other stuff with broken dependencies can and should be blocked, but not PackageKit-zif, because it is a subpackage of PackageKit which definitely needs to go into Everything.)
Comment 6 Adam Williamson 2011-10-27 18:51:18 EDT
that sounds about right to me - is that okay for you, dennis / bill?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Adam Williamson 2011-10-28 01:48:21 EDT
btw, this is a clear blocker per the criteria:

"here must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install "

I'm just gonna set it straight to AcceptedBlocker, because we always accept these.
Comment 8 Dennis Gilmore 2011-10-28 08:56:46 EDT
im happy to exclude PackageKit-zif from making it to the DVD.
Comment 9 Bill Nottingham 2011-10-28 14:50:41 EDT
I'm happy with either the exclude, or pulling the update into final. (or both, for that matter.)
Comment 10 Adam Williamson 2011-10-28 15:01:03 EDT
discussed at 2011-10-28 blocker review meeting. We agreed it seems like the best fix is to do both the exclusion of PackageKit-zif from the DVD, and the pulling of the update into the stable repos to avoid scripts complaining about dependency issues forever more.
Comment 11 Adam Williamson 2011-10-28 15:41:40 EDT
Assigning to Dennis as he's doing the composes.
Comment 12 Andre Robatino 2011-10-29 04:46:54 EDT
This is fixed in the 16.RC1 DVDs (no repoclosure or file conflicts issues).
Comment 13 Adam Williamson 2011-10-29 13:10:16 EDT
Let's close it, then!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers