Bug 749843

Summary: [abrt] yum-3.4.3-5.fc16: yummain.py:51:exIOError:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 18: ordinal not in range(128)
Product: [Fedora] Fedora Reporter: João Paulo <jpaulobneto>
Component: yumAssignee: Seth Vidal <skvidal>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: desintegr, ffesti, james.antill, maxamillion, pmatilai, tla, vpvainio, zpavlas
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:2b2dbeadd724cafb0d2db92cd8e211135e597b7d
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-31 05:07:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description João Paulo 2011-10-28 13:15:40 EDT
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        /usr/bin/python /usr/bin/yum -d 0 -C list available syna*
comment:                   
executable:     /usr/bin/yum
kernel:         3.1.0-1.fc16.i686
reason:         yummain.py:51:exIOError:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 18: ordinal not in range(128)
time:           Fri Oct 28 10:49:52 2011
uid:            1000
username:       jpaulobneto

backtrace:
:yummain.py:51:exIOError:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 18: ordinal not in range(128)
:
:Traceback (most recent call last):
:  File "/usr/bin/yum", line 29, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
:    errcode = main(args)
:  File "/usr/share/yum-cli/yummain.py", line 149, in main
:    return exIOError(e)
:  File "/usr/share/yum-cli/yummain.py", line 51, in exIOError
:    logger.critical(_('\n\n%s') % exception2msg(e))
:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 18: ordinal not in range(128)
:
:Local variables in innermost frame:
:unlock: <function unlock at 0xb7150a04>
:e: IOError(13, 'Permiss\xc3\xa3o negada')
:logger: <logging.Logger object at 0xb714eccc>

smolt_data:
:
:
:Geral
:=================================
:UUID: 74ddced3-5d99-4822-8448-38c2d78b13b3
:SO: Fedora release 16 (Verne)
:Nível de execução padrão: Unknown
:Idioma: pt_BR.utf8
:Plataforma: i686
:BogoMIPS: 5625.99
:Fabricante da CPU: AuthenticAMD
:Modelo da CPU: AMD Phenom(tm) II X6 1055T Processor
:Versão da CPU: 0
:Família da CPU: 16
:Modelo da CPU: 10
:Número de CPUs: 6
:Velocidade da CPU: 2800
:Memória do sistema: 2773
:Swap do sistema: 951
:Fabricante: System manufacturer
:Sistema: System Product Name System Version
:Fator de uso: Desktop
:Kernel: 3.1.0-1.fc16.i686
:SELinux habilitado: 1
:Politica do SELinux: targeted
:Modo de reforço do SELinux: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Dispositivos
:=================================
:(4318:1014:4163:33700) pci, sata_nv, STORAGE, MCP61 SATA Controller
:(4318:1014:4163:33700) pci, sata_nv, STORAGE, MCP61 SATA Controller
:(4318:1004:4163:33700) pci, pata_amd, STORAGE, MCP61 IDE
:(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4318:982:4163:33700) pci, nouveau, VIDEO, C61 [GeForce 7025 / nForce 630a]
:(4318:1000:4318:0) pci, pcieport, PCI/PCI, MCP61 PCI Express bridge
:(4318:1009:4163:33700) pci, ohci_hcd, USB, MCP61 USB Controller
:(4318:1010:4163:33700) pci, ehci_hcd, USB, MCP61 USB Controller
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4318:1001:4318:0) pci, pcieport, PCI/PCI, MCP61 PCI Express bridge
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4318:1011:4163:33700) pci, None, PCI/PCI, MCP61 PCI bridge
:(4318:1007:4163:33700) pci, forcedeth, BRIDGE, MCP61 Ethernet
:(4318:1001:4318:0) pci, pcieport, PCI/PCI, MCP61 PCI Express bridge
:(4318:994:4163:33700) pci, None, RAM, MCP61 LPC Bridge
:(4318:1008:4163:33804) pci, snd_hda_intel, MULTIMEDIA, MCP61 High Definition Audio
:(4318:1013:4163:33700) pci, None, RAM, MCP61 Memory Controller
:(4318:1003:4163:33700) pci, nForce2_smbus, SERIAL, MCP61 SMBus
:(4318:993:4163:33700) pci, None, PCI/ISA, MCP61 LPC Bridge
:
:
:Informações do sistema de arquivos
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sdb5 / ext4 4096 4096 16580780 15635231 15466839 4218880 4100018 4100018
:/dev/sdb4 WITHHELD fuseblk 4096 4096 30719743 10908218 10908218 43763944 43736370 43736370
:
Comment 1 Damien Gombault 2011-10-28 14:01:44 EDT
This bug seems to be a duplicate of bug 749239.
Comment 2 Ville-Pekka Vainio 2011-10-30 13:27:00 EDT
Package: yum-3.4.3-5.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
This happened when doing a "yum update" with a local rpm. Maybe this is somehow related to bash-completion?
Comment 3 Zdeněk Pavlas 2011-10-31 05:07:39 EDT

*** This bug has been marked as a duplicate of bug 749239 ***