Bug 749868

Summary: Wrong-code bugfixes in GCC 4.6.2
Product: [Fedora] Fedora Reporter: Jakub Jelinek <jakub>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: awilliam, dmalcolm, jakub
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedNTH
Fixed In Version: gcc-4.6.2-1.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 739766 Environment:
Last Closed: 2011-10-29 02:32:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 713566    

Description Jakub Jelinek 2011-10-28 14:23:48 EDT
+++ This bug was initially created as a clone of Bug #739766 +++

If all these 3 packages could make it into f16, it would be nice, with the f16 glibc gcc doesn't build otherwise.
There have been important wrong-code bugfixes in this gcc, like e.g.
http://gcc.gnu.org/PR49279 where GCC miscompiled Eigen2 or
http://gcc.gnu.org/PR50700 which is a -D_FORTIFY_SOURCE=2 wrong-code or
http://gcc.gnu.org/PR50189 (another miscompilation) just to name a few.
GCC is from a stable branch limited for regression bugfixes and documentation fixes and has been thoroughly tested   There has been no changes in libgcc nor libstdc++ (subpackages because of which gcc is CRITPATH).

--- Additional comment from awilliam@redhat.com on 2011-10-28 14:05:42 EDT ---

jakub: this bug was filed for the python plugin, not gcc itself. if you want that update pulled into final (and it does look like a good NTH candidate) we should use a different bug.
Comment 1 Jakub Jelinek 2011-10-28 14:30:12 EDT
https://admin.fedoraproject.org/updates/gcc-4.6.2-1.fc16,libtool-2.4-7.fc16
(plus gcc-python-plugin would need to be updated too).
Already during the package build gcc performs many thousands of tests and there have been no regressions since the gcc in F16 right now.
Comment 2 Fedora Update System 2011-10-28 14:57:53 EDT
gcc-4.6.2-1.fc16, libtool-2.4-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gcc-4.6.2-1.fc16,libtool-2.4-7.fc16
Comment 3 Adam Williamson 2011-10-28 15:40:24 EDT
Discussed at 2011-10-28 NTH review meeting, accepted as NTH due to severity of impact, people may need to compile stuff when booted live. It would be fine to edit the update to pull in the gcc-python-plugin rebuild to avoid dep issues in the repos.
Comment 4 Jakub Jelinek 2011-10-28 15:49:23 EDT
Can some provenpackager do it? I don't have ACLs for gcc-python-plugin and thus can't add gcc-python-plugin to the bodhi request.
Comment 5 Fedora Update System 2011-10-28 17:32:21 EDT
Package gcc-4.6.2-1.fc16, libtool-2.4-7.fc16, gcc-python-plugin-0.6-4.2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gcc-4.6.2-1.fc16 libtool-2.4-7.fc16 gcc-python-plugin-0.6-4.2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15040
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-10-29 02:32:46 EDT
gcc-4.6.2-1.fc16, libtool-2.4-7.fc16, gcc-python-plugin-0.6-4.2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Dave Malcolm 2011-11-22 11:52:39 EST
(In reply to comment #4)
> Can some provenpackager do it? I don't have ACLs for gcc-python-plugin and thus
> can't add gcc-python-plugin to the bodhi request.

Jakub: if you want the ACLs on that plugin, go to:
  https://admin.fedoraproject.org/pkgdb/acls/name/gcc-python-plugin
and request them (assuming that you're logged in to the web UI).  (There doesn't seem to be a way for me to directly add you to the package).