This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 749942

Summary: var-lib-nfs-rpc_pipefs.mount fails without a meaningful error message
Product: [Fedora] Fedora Reporter: Andrew McNabb <amcnabb>
Component: systemdAssignee: systemd-maint
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: johannbg, lpoetter, metherid, mschmidt, notting, plautrba, rmarko, systemd-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-29 06:34:04 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Andrew McNabb 2011-10-28 19:28:29 EDT
Description of problem:

NFS idmapd isn't started because the "RPC Pipe File System" fails to mount. Specifically, boot.log shows:

Starting RPC Pipe File System ESC[1;31mfailedESC[0m, see 'systemctl status var-lib-nfs-rpc_pipefs.mount' for details.
Starting NFSv4 ID-name mapping daemon ESC[1;31mabortedESC[0m because a dependency failed.

The output of "systemctl status var-lib-nfs-rpc_pipefs.mount" is:

var-lib-nfs-rpc_pipefs.mount - RPC Pipe File System
	  Loaded: loaded (/lib/systemd/system/var-lib-nfs-rpc_pipefs.mount; static)
	  Active: active (mounted) since Fri, 28 Oct 2011 17:04:08 -0600; 16min ago
	   Where: /var/lib/nfs/rpc_pipefs
	    What: sunrpc
	 Process: 384 ExecMount=/bin/mount sunrpc /var/lib/nfs/rpc_pipefs -t rpc_pipefs (code=exited, status=32)
	  CGroup: name=systemd:/system/var-lib-nfs-rpc_pipefs.mount

Oddly, when the mountpoint appears to be mounted correctly--the output of "grep sunrpc /proc/mounts" is:

sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw,relatime 0 0

Unfortunately, I cannot find any error messages in the logs to illuminate what is happening.


Version-Release number of selected component (if applicable):

systemd-37-2.fc16.x86_64


How reproducible:

every boot


Steps to Reproduce:
1. Boot.

  
Actual results:

The idmapd service is not running. There are no meaningful error messages.


Expected results:

The idmapd service should be running. If it fails to run, there should be meaningful error messages.


Additional info:
Comment 1 Richard Marko 2011-10-29 06:34:04 EDT

*** This bug has been marked as a duplicate of bug 744463 ***