This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 750021

Summary: [abrt] telepathy-butterfly-0.5.15-3.fc16: connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/xxxxxxxxxxxxxxxxxxx_40hotmail_2ecom at 0x265d210>
Product: [Fedora] Fedora Reporter: s.tousignant
Component: telepathy-butterflyAssignee: Brian Pepple <bdpepple>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: bdpepple, sander
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:24abd3d8cf719b6aae578fa80474b1e1a8bf9a8b
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-11-20 09:51:28 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description s.tousignant 2011-10-29 21:33:49 EDT
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        /usr/bin/python /usr/libexec/telepathy-butterfly
comment:        Try to connect to an msn account with an upgraded profil
executable:     /usr/libexec/telepathy-butterfly
kernel:         3.1.0-0.rc8.git0.1.fc16.x86_64
reason:         connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/therealplanestraveler_40hotmail_2ecom at 0x265d210>
reported_to:    file: /tmp/abrt.log
time:           Sat Oct 29 21:27:26 2011
uid:            500
username:       steve

backtrace:
:connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/xxxxxxxxxxxxxxxxxxx_40hotmail_2ecom at 0x265d210>
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 425, in disconnected
:    self._state = ClientState.CLOSED
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 319, in fset
:    self._dispatch("on_client_state_changed", state)
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 44, in _dispatch
:    if event_handler._dispatch_event(name, *args):
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
:    handler(*params)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 393, in on_client_state_changed
:    self._disconnected()
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 286, in _disconnected
:    self._manager.disconnected(self)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection_manager.py", line 51, in disconnected
:    result = telepathy.server.ConnectionManager.disconnected(self, conn)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/connmgr.py", line 65, in disconnected
:    self._connections.remove(conn)
:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/xxxxxxxxxxxxxxxxxxx_40hotmail_2ecom at 0x265d210>
:
:Local variables in innermost frame:
:self: <butterfly.connection_manager.ButterflyConnectionManager at /org/freedesktop/Telepathy/ConnectionManager/butterfly at 0x2655910>
:conn: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/xxxxxxxxxxxxxxxxxxx_40hotmail_2ecom at 0x265d210>

event_log:
:2011-10-29-21:34:43> Smolt profile successfully saved
:2011-10-29-21:35:51> The report was appended to /tmp/abrt.log

smolt_data:
:
:
:Général
:=================================
:UUID: 5c3f1802-ceab-4cef-8760-67fae0245eb0
:SE: Fedora release 16 (Verne)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_CA.utf8
:Plateforme: x86_64
:BogoMIPS: 3590.31
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM)2 Duo CPU     T7100  @ 1.80GHz
:Stepping du processeur: 13
:Famille de processeur: 6
:Modèle du processeur: 15
:Nombre de processeurs: 2
:Vitesse du processeur: 1801
:Mémoire du système: 1995
:Swap du système: 4031
:Fabricant: Sony Corporation
:Système: VGN-FZ140QE C3LP5B55
:Type d'ordinateur: Notebook
:Noyau: 3.1.0-0.rc8.git0.1.fc16.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(4523:17233:4173:36869) pci, sky2, ETHERNET, 88E8036 PCI-E Fast Ethernet Controller
:(32902:10752:4173:36869) pci, agpgart-intel, HOST/PCI, Vaio VGN-FZ260E
:(32902:10302:4173:36869) pci, i801_smbus, SERIAL, Vaio VGN-FZ260E
:(32902:10281:4173:36869) pci, ahci, STORAGE, Vaio VGN-FZ260E
:(32902:10320:4173:36869) pci, ata_piix, STORAGE, Vaio VGN-FZ260E
:(32902:10261:4173:36869) pci, None, PCI/ISA, Vaio VGN-FZ260E
:(32902:10307:4173:36869) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 3
:(32902:9288:4173:36869) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10289:4173:36869) pci, uhci_hcd, USB, Vaio VGN-FZ260E
:(32902:10288:4173:36869) pci, uhci_hcd, USB, Vaio VGN-FZ260E
:(32902:10290:4173:36869) pci, uhci_hcd, USB, Vaio VGN-FZ260E
:(4172:32827:4173:36869) pci, tifm_7xx1, STORAGE, 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
:(32902:10294:4173:36869) pci, ehci_hcd, USB, Vaio VGN-FZ260E
:(32902:10298:4173:36869) pci, ehci_hcd, USB, Vaio VGN-FZ260E
:(32902:10754:4173:36869) pci, i915, VIDEO, Mobile GM965/GL960 Integrated Graphics Controller (primary)
:(32902:10755:4173:36869) pci, None, VIDEO, Mobile GM965/GL960 Integrated Graphics Controller (secondary)
:(32902:10303:4173:36869) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 1
:(32902:10305:4173:36869) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 2
:(32902:10311:4173:36869) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 5
:(32902:10315:4173:36869) pci, snd_hda_intel, MULTIMEDIA, Vaio VGN-FZ260E
:(32902:16937:32902:4352) pci, iwl4965, NETWORK, Vaio VGN-SZ79SN_C
:(32902:10292:4173:36869) pci, uhci_hcd, USB, Vaio VGN-FZ260E
:(32902:10293:4173:36869) pci, uhci_hcd, USB, Vaio VGN-FZ260E
:(4172:32825:4173:36869) pci, yenta_cardbus, PCI/CARDBUS, PCIxx12 Cardbus Controller
:(4172:32826:4173:36869) pci, firewire_ohci, FIREWIRE, PCIxx12 OHCI Compliant IEEE 1394 Host Controller
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_planeslaptop-lv_root / ext4 4096 4096 12901535 9458590 9327560 3276800 2977725 2977725
:/dev/sda1 /boot ext4 1024 1024 495844 280046 254446 128016 127763 127763
:/dev/mapper/vg_planeslaptop-lv_home /home ext4 4096 4096 20875918 11827480 10767026 5308416 4965041 4965041
:
Comment 1 s.tousignant 2011-10-29 21:34:18 EDT
Package: telepathy-butterfly-0.5.15-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Try to connect to an msn account with an upgraded profil
Comment 2 Brian Pepple 2011-11-20 09:51:28 EST

*** This bug has been marked as a duplicate of bug 691209 ***