Bug 750052

Summary: libreoffice does not recognize java-1.7.0-openjdk
Product: [Fedora] Fedora Reporter: Martin Jürgens <ma>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: caolanm, dtardon, erack, ltinkl, mstahl, nojunk311, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-30 13:07:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Martin Jürgens 2011-10-30 08:29:51 EDT
Description of problem:
libreoffice does not recognize java-1.7.0-openjdk. this means the JRE is not listed in the settings dialog and that functions requiring a JRE do not work when only having java-1.7.0 installed.
Comment 1 David Tardon 2011-10-30 13:07:16 EDT
this has been fixed in libreoffice-3.4.3.2-15.fc16
Comment 2 HughieB 2012-02-17 00:24:03 EST
This has unfixed in libreoffice-3.4.5.2-5.fc16
Comment 4 David Tardon 2012-02-17 01:56:36 EST
(In reply to comment #3)
> This looks like the fix:
> http://cgit.freedesktop.org/libreoffice/core/commit/?id=549e54fb2f8113502743c443d6deadfe648dede1

We had that patch in our package since libreoffice-3.4.3.2-15.fc16 and it was integrated in upstream version 3.4.5.1. Works fine here, too.