This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 751723

Summary: can't enable gnome-shell-extension-systemMonitor
Product: [Fedora] Fedora Reporter: Sam Tygier <samtygier>
Component: gnome-shell-extensionsAssignee: Rahul Sundaram <metherid>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: adrigiga, metherid, michel, pikachu.2014, timur.kristof
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-18 11:10:26 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Sam Tygier 2011-11-07 06:02:07 EST
Description of problem:
I have installed gnome-shell-extension-systemMonitor in fedora 16. I have logged out and in again. there is still no system monitor in my gnome shell. I can find no way to enable it.

The package does not contain any documentation. The gnome help has not docs on extensions. The gnome shell website make it look as if extensions are enabled once they are installed. I cant find any gui to enable extensions.

Version-Release number of selected component (if applicable):
Installed Packages
Name        : gnome-shell-extension-systemMonitor
Arch        : noarch
Version     : 3.2.0
Release     : 1.fc16
Size        : 4.9 k
Repo        : installed
From repo   : updates
Summary     : Monitor your system status
URL         : http://live.gnome.org/GnomeShell/Extensions
License     : GPLv2+
Description : Monitor your system status

How reproducible:
I have installed it on one computer,

Steps to Reproduce:
1.sudo yum install gnome-shell-extension-systemMonitor
2. log out and in
3. check gnome shell fro a system monitor
  
Actual results:
nothing

Expected results:
system monitor in top panel, or a gui somewhere to enable it

Additional info:
Comment 1 Mohamed El Morabity 2011-11-07 06:20:51 EST
This extension, once enabled, is located in the activities view, on the lower left corner. It consists in two small graphs: one for the CPU activity, the other for the network activity. If you see nothing, it's a bug, if you see the graphs and don't like it, you should submit an enhancement request to the GNOME Bugzilla.
Comment 2 Sam Tygier 2011-11-07 08:05:49 EST
assuming the activities view is the one i get after moving the mouse to the top left, or pressing the super button, I do not see any graphs.
Comment 3 adriano 2011-11-07 14:44:15 EST
Same problem for me.
Installed gnome-shell-extension-systemMonitor-3.2.0-1.fc16.noarch but no graphs neither in the top bar nor in activities view.
Comment 4 adriano 2011-11-07 15:55:30 EST
some informations:
in gnome shell looking glass, in the "Extensions" tab, my two extensions - "System Monitor" and "Places Status Indicator" - appears disabled. 
executing:  gsettings get org.gnome.shell disabled-extensions
returns: No such key 'disabled-extensions'

How to enable them?

I have updated my Fedora 15 with preupgrade 4 days ago and today (7/11) I have installed all updates available.
Comment 5 Sam Tygier 2011-11-07 17:09:43 EST
i tried adjusting the version number as described in the comments on
https://justinstories.wordpress.com/2011/05/27/five-must-have-gnome-shell-extensions-for-fedora-15/
and restarted GS but it did not help.
Comment 6 Mohamed El Morabity 2011-11-09 09:51:08 EST
Just to avoid any ambiguities:
- when installing a new extension in GNOME 3.2, it is not enabled by default; it must be manually enabled. The easiest way to achieve this is to use gnome-tweak-tool. The command below lists all the enabled extensions:
    $ gsettings get org.gnome.shell enabled-extensions
   If its return doesn't contain « systemMonitor@gnome-shell-extensions.gnome.org », then systemMonitor is *not* enabled.
- once enabled, the systemExtension extension looks like this:
    http://imageshack.us/photo/my-images/209/capturedu20111109152044.png/
Comment 7 adriano 2011-11-10 06:17:05 EST
(In reply to comment #6)
> Just to avoid any ambiguities:
> - when installing a new extension in GNOME 3.2, it is not enabled by default;
> it must be manually enabled. The easiest way to achieve this is to use
> gnome-tweak-tool. The command below lists all the enabled extensions:
>     $ gsettings get org.gnome.shell enabled-extensions
>    If its return doesn't contain «
> systemMonitor@gnome-shell-extensions.gnome.org », then systemMonitor is *not*
> enabled.
> - once enabled, the systemExtension extension looks like this:
>     http://imageshack.us/photo/my-images/209/capturedu20111109152044.png/

Mohamed, thanks for your help. The new behavior of gnome-shell has left me confused. Now extensions are up and running. 
For my point of view this bug is closed.
Comment 8 Mohamed El Morabity 2011-12-18 11:10:26 EST
If there is any objection, I will consider this "bug" solved. Feel free to reopen if needed.