Bug 752455

Summary: [abrt] systemd-gtk-37-3.fc16: strlen: Process /usr/bin/systemadm was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Lukas Middendorf <lukas+fedora>
Component: systemdAssignee: systemd-maint
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: johannbg, lpoetter, metherid, mschmidt, notting, plautrba, systemd-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:816e869ecc7fffcee66fa8a1919c68cdc4081699
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-20 10:41:52 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: environ
none
File: dso_list
none
File: maps
none
File: backtrace none

Description Lukas Middendorf 2011-11-09 10:09:20 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        systemadm
crash_function: strlen
executable:     /usr/bin/systemadm
kernel:         3.1.0-7.fc16.x86_64
pid:            1882
pwd:            /home/lukas
reason:         Process /usr/bin/systemadm was killed by signal 11 (SIGSEGV)
time:           Wed 09 Nov 2011 04:00:42 PM CET
uid:            1000
username:       lukas

backtrace:      Text file, 23887 bytes
dso_list:       Text file, 4479 bytes
environ:        Text file, 3534 bytes
maps:           Text file, 28610 bytes

build_ids:
:1c6a95451ee19617be5abea3d121f0226d21ddda
:aaf7ed41612348bd1141db06cadd428244aa6ea5
:ec72f897bbac2f33aadee57e01b7e01bbed4c534
:44ece411beb2ef1acdb5eb2161666de41cc2f31d
:98fa95d21e16075ada6df19748c6c133ee9165d0
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:87461d97d0ba0bd94e4d74ff0879190b67b326c5
:c2d49d72ec1a1e68b39c3724693f83f44d80a259
:7110c8ac5ea9a650cbf77c51e8cc1df7c407fafd
:a594ab36356a9b6dc6ecf25a6124463ccbfd0a29
:30af62b93e2ab7dbaf39c52e346cd52101b4b590
:f0d50e3af2dfee021a327fb85a993a2312a98145
:9af722e8d4717709aa49739efc0ed10d0f952e3e
:36a149d1e2c29890b616402f6bc5e3f69ca2738e
:48d3cff26c916dff6cbcb5e67d5cf6d391f6ccca
:8264e35452b2a930c1b9b092b87f32d42d69d8c5
:aaf62304b0fc10611d35b4f56005479d4c58868d
:c8a4e40c84c2f52e78c64d31efc0191c565a9049
:8acc43df965b3c0a70dcfad11c0ade056bdb055b
:163b323da65b708418226eb5fa8b057c731d1475
:6ecc3efaedf849a17c30a67fe15b4dacca1bd981
:0911ea7c180d733724f89037b8e8a34e64024aec
:037b990d1ee7952a2b96368b49d602a480bf62a7
:94bb5d62af9c20747265eb4bb1d2179e1ece1c6b
:48aea888319e1848137073c9cbde54a4c2a731c9
:4953d1f613914126bccceb3cb96386647ffba9df
:4c842320387ff7f6f91b7842b223c16518be909f
:4d41331c003983b4df9034310b3f42df039a0250
:9d1209fc79304f03cc839de1c0036c61b48dfff8
:017a0c9c46d30256c1d6af189b4809146ef312f6
:7994f114cf7189e482f2665fae8e351ed8bc05e3
:94e29139152ba767534403cf94a672fe6b3fe515
:be507c791e34415e8f42f0e6030c889b2895cf9a
:07470201df55a5254027d05fa4dc509b10f2986a
:3d22dd762f2430ac679e61c98e8d856e5f3423ed
:91689252818532ec13597b6528d38be93b2706c4
:e5d7ac2dfe435e205e491f7ce827563859fca4f4
:3e2404bd469800afd61eda83d0292a2165ef0db0
:fc4728c6cba9c205417e8cae9c5128b58c7a1e40
:3b50812827b755646178db9447ced77425add5d8
:11307731c4aa95e08b6de3064d064a12d12dee8f
:56d0d755b880afdd9ebf2c8c707282384fed90fd
:d440afe7396b3365dcb935f9bf7f2fb28f3839de
:650b733aecfb9c46bdfc023661f19244a278df04
:a518a8b1b5c3e80dee813df05e951d205d6ac48c
:5f68fecc89bbb7cf2200b4caed6fb26006a189b7
:b67d01f9230119a215e7151dc3aa43428b886c8f

comment:
:1. start systemadm
:2. in a terminal run "systemctl stop sshd.service"
:
:crashes also for any other service and also for start, enable and disable (and likely others as well) commands.

var_log_messages:
:Nov  9 01:12:33 ip30-161 kernel: [  985.044953] systemadm[2234]: segfault at 8 ip 00007f386e9a0b36 sp 00007fffca37c590 error 4 in libgio-2.0.so.0.3000.1[7f386e8f5000+139000]
:Nov  9 01:12:34 ip30-161 abrt[2330]: saved core dump of pid 2234 (/usr/bin/systemadm) to /var/spool/abrt/ccpp-2011-11-09-01:12:33-2234 (15642624 bytes)
:Nov  9 02:20:11 ip30-161 kernel: [  762.206935] systemadm[2142]: segfault at 3800000008 ip 0000003827686761 sp 00007fff96f15d08 error 4 in libc-2.14.90.so[3827600000+1aa000]
:Nov  9 02:20:11 ip30-161 abrt[2285]: saved core dump of pid 2142 (/usr/bin/systemadm) to /var/spool/abrt/ccpp-2011-11-09-02:20:11-2142 (15216640 bytes)
:Nov  9 03:07:10 ip30-161 kernel: [  347.093770] systemadm[1887]: segfault at 3800000008 ip 0000003827686761 sp 00007fffcef11db8 error 4 in libc-2.14.90.so[3827600000+1aa000]
:Nov  9 03:07:11 ip30-161 abrt[2262]: saved core dump of pid 1887 (/usr/bin/systemadm) to /var/spool/abrt/ccpp-2011-11-09-03:07:10-1887 (17289216 bytes)
:Nov  9 15:14:45 ip30-161 abrt[2581]: Saved core dump of pid 2168 (/usr/bin/systemadm) to /var/spool/abrt/ccpp-2011-11-09-15:14:45-2168 (16646144 bytes)
:Nov  9 16:00:42 ip30-161 kernel: [   92.023490] systemadm[1882]: segfault at c ip 0000003827686761 sp 00007fff5449c2d8 error 4 in libc-2.14.90.so[3827600000+1aa000]
:Nov  9 16:00:43 ip30-161 abrt[2019]: Saved core dump of pid 1882 (/usr/bin/systemadm) to /var/spool/abrt/ccpp-2011-11-09-16:00:42-1882 (16498688 bytes)
Comment 1 Lukas Middendorf 2011-11-09 10:09:24 EST
Created attachment 532582 [details]
File: environ
Comment 2 Lukas Middendorf 2011-11-09 10:09:27 EST
Created attachment 532583 [details]
File: dso_list
Comment 3 Lukas Middendorf 2011-11-09 10:09:31 EST
Created attachment 532584 [details]
File: maps
Comment 4 Lukas Middendorf 2011-11-09 10:09:33 EST
Created attachment 532585 [details]
File: backtrace
Comment 5 Michal Schmidt 2012-03-20 10:41:52 EDT

*** This bug has been marked as a duplicate of bug 744439 ***