Bug 752723

Summary: Fedora 16 Will not install on Lenovo W520 in discrete Graphics Mode (Nvidia 1000M)
Product: [Fedora] Fedora Reporter: Vincent passaro <vincent.passaro>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: chillermillerlong, dennis, gansalmon, gordon+rhbugs, itamar, jadams1217, jonathan, kernel-maint, korsnick, madhu.chinakonda, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-09-04 10:08:07 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Vincent passaro 2011-11-10 03:55:38 EST
Description of problem:

Fedora will not install on Lenovo W520 with Nvidia Graphics Card 1000M.


Version-Release number of selected component (if applicable):  

Fedora 16


How reproducible:

Always


Steps to Reproduce:
1. Put DVD in DVD Rom
2. Boot to DVD
3. Select Install Fedora
4. Error occurs and install stop:

systemd[1]: Failed to fully start up daemon.  No such file or directory.

  
Actual results: 

Fedora Does not install


Expected results:

Fedora should install.


Additional info:
Comment 1 Bill Nottingham 2011-11-10 11:59:57 EST
Does it work in non-discrete mode?
Comment 2 Vincent passaro 2011-11-10 13:58:38 EST
Yes, it does install in when selecting integrated graphics mode.
Comment 3 Chris Lumens 2011-11-11 08:34:38 EST
Please attach the complete error message you are seeing.  The systemd message alone is likely not the real problem here.
Comment 4 Vincent passaro 2011-11-13 22:49:54 EST
That message is the complete message displayed on the screen.  I can't jump to any other VTY's or anything to try and get any other information.
Comment 5 Josh Adams 2011-11-19 12:35:29 EST
As I mentioned at https://bugzilla.redhat.com/show_bug.cgi?id=752613

This seems to be an issue with the hardware vitualization being enabled.  Hopefully this narrows down the problem and someone can fix it cause I've been having this issue since Fedora 15 (haven't tried earlier versions, but Arch Linux works fine).
Comment 6 Vincent passaro 2011-11-23 03:16:55 EST
Same.  Still is not working
Comment 7 Xiao-Long Chen 2011-12-06 18:32:35 EST
As a temporary workaround, you can boot with "noapic", which does not affect any functionality (as opposed to disabling hardware virtualization).
Comment 8 Dave Jones 2012-03-22 12:46:15 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 9 Dave Jones 2012-03-22 12:50:55 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 10 Dave Jones 2012-03-22 13:00:52 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 11 Xiao-Long Chen 2012-03-22 15:14:26 EDT
@Dave: Thanks for the reply. I've tested with and without Nouveau (nVidia proprietary driver's kernel module won't compile). Without Nouveau, I was able to boot the system with the default kernel parameters (i.e. without noapic). With Nouveau, Fedora still crashes at the initrd stage (probably during udev initialization, like in other distros).
Comment 12 GordonL 2012-03-29 02:51:18 EDT
@Dave - this worked great for me!  I was suffering this exact problem on my Lenova W520 in Discrete Graphics mode.  I ended up using the noapic boot parameter as a workaround, but this is no longer needed for me after updating to kernel-3.3.0-4!
Comment 13 patrick korsnick 2012-03-29 19:34:17 EDT
@GordonL are you running the closed source nvidia driver? I tried removing noapic from kernel params on 3.3.0-4 and 3.3.0-5 (f17) both running nouveau and machine fails to boot.
Comment 14 GordonL 2012-04-04 15:56:43 EDT
@Patrick: I am using Nouveau.  I previously tried the Nvidia driver when I was wrestling with this bug, but was never able to get that to work.  My /var/log/Xorg.0.log says:

[    56.489] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[    56.489] (II) Module nouveau: vendor="X.Org Foundation"
[    56.489]    compiled for 1.10.99.902, module version = 0.0.16
[    56.489]    Module class: X.Org Video Driver
[    56.489]    ABI class: X.Org Video Driver, version 11.0

I previously needed the noapic Kernel option for the machine to boot, but after upgrading to kernel 3.3.0.4 I was able to remove noapic and it is still working great!
Comment 15 GordonL 2012-04-09 18:40:37 EDT
Here are two more notes which may or may not be useful to someone:

1) I've now upgraded to kernel 3.3.1-3.fc16.x86_64 and the fix is still working.  I verified on the grub command line that noapic=1 is NOT specified.

2) I have Intel Virtualization Technology Enabled (this is key because, previously, I could disable this rather than specify noapic=1).  However, I have the "Intel VT-d" feature disabled.  That feature (VT-d) is not required for me to run VMWare.  I'm not sure if enabling it would cause any problems for me (haven't tried).
Comment 16 patrick korsnick 2012-04-10 11:26:29 EDT
i'm also running 3.3.1-3.fc17.x86_64 and have the same Virtulization settings and my machine will _not_ boot without 'noapic' in the kernel parameters.

I restored the default settings in the BIOS and then changed the graphics from Optimus to Discrete. This was the only change from default settings.

BIOS Information
        Vendor: LENOVO
        Version: 8BET53WW (1.33 )
        Release Date: 10/21/2011


        Firmware Revision: 1.25

Machine will boot if in Optimus mode _without_ 'noapic' but put it in Discrete and it hangs without 'noapic'.
Comment 17 GordonL 2012-04-12 04:06:29 EDT
Hi Patrick.  My BIOS is a little bit newer:

UEFI BIOS Version: 8BET55WW (1.35)
UEFI BIOS Release Date: 2011-12-06

I'm not sure where to get the firmware version you referenced.  I do see this on my BIOS info screen:

Embedded Controller: 8A4T38WW (1.20)

If you turn off Intel Virtualization Technology, does it work for you even without noapic=1?  Of course this doesn't help if you need the feature (like I do).

It has always worked for me in integrated graphics mode, but I can't use that as I commonly plug the system into a 30" external monitor using DisplayPort (through a docking station).  As far as I know, this can't be done with the integrated graphics system.

It is too bad that the "fix" doesn't seem to be working for everyone.  I never saw any particular negative side effects when I was using noapic=1, but I am glad that I no longer seem to need it after the fix.
Comment 18 Josh Boyer 2012-09-04 10:08:07 EDT
This seems to be resolved and/or some sort of firmware issue.

If this is still being seen on F16 3.4 kernels or F17 3.5 kernels, please open a new bug.