Bug 752727

Summary: We can not work with Fedora 15, 16, because does not work the display backlight
Product: [Fedora] Fedora Reporter: Ihor <piv986>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 16CC: brentrbrian, collura, dennis, e859787, frsepulv.linux, gansalmon, itamar, jforbes, jonathan, kernel-maint, madhu.chinakonda, p.scott, ttocsretep
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-14 10:17:38 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
acpi dump none

Description Ihor 2011-11-10 04:01:26 EST
Description of problem:

When booting from liveCD not working display backlight.
Tested on emachines 525. Intel GMA 4500M graphics card.


Version-Release number of selected component (if applicable):


How reproducible:
Booting Fedora 16 with a livecd

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Josh Boyer 2011-11-10 12:10:43 EST
Can you provide the output of acpidump for these machines, as well as the output of "ls /sys/class/backlight/*"
Comment 2 Brent R Brian 2011-11-22 21:15:27 EST
Acer Aspire 5734-Z4836 which runs fine on F14.

I tried to boot F15 & F16 on this machine:

* The screen goes blank.
* Backlight is off.
* ALT-F keys don't work 
* The CD just spins forever ...

Get same results if I turn off graphic/boot login and quiet (F16).

If you can get me to a prompt where I can startx (or another method of your choice) I will be glad to assist.

I live down the road from your Raleigh campus.

B
Comment 3 Brent R Brian 2011-11-22 21:27:38 EST
BTW -- xdriver=vesa parm did not help
Comment 4 Francisco Sepulveda V. 2011-11-29 15:47:11 EST
I get the same behavior on a eMachines E725 w/Fedora 16 while booting from:

- LiveCD
- Installation DVD
- HDD

It starts normally but backlight gets turned off a few seconds after the boot image starts loading (as far as I can tell). Sometimes, playing with the backlight settings through the keyboard (changing its brightness or turning it on/off repeatedly) makes it stay turned on.

Default settings were used on all boot attempts.
Comment 5 Brent R Brian 2011-12-13 16:17:40 EST
The xdriver=vesa nomodeset works
Comment 6 Brent R Brian 2011-12-16 19:29:36 EST
Created attachment 548022 [details]
acpi dump
Comment 7 Brent R Brian 2011-12-16 19:30:23 EST
[brent@brent-laptop ~]$ ls /sys/class/backlight/*
/sys/class/backlight/acpi_video0:
actual_brightness  brightness  max_brightness  subsystem  uevent
bl_power           device      power           type

/sys/class/backlight/intel_backlight:
actual_brightness  brightness  max_brightness  subsystem  uevent
bl_power           device      power           type
[brent@brent-laptop ~]$ 

acpidump.txt attached

Acer Aspire 5734Z-4836
Comment 8 Brent R Brian 2011-12-19 06:29:42 EST
Acer Aspire using intel drivers:

# works
# echo "400" > /sys/class/backlight/intel_backlight/brightness
# /sys/class/backlight/intel_backlight/brightness == 0 on boot

# does not work
# reinstalling bash

# does not work - adding this kernel parm
# acpi_backlight=vendor

Using a second monitor to get the thing up and running.  If you need something tested, let me know.
Comment 9 Dave Jones 2012-03-22 12:44:32 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 10 Dave Jones 2012-03-22 12:48:56 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 11 Dave Jones 2012-03-22 12:58:18 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 12 Brent R Brian 2012-03-22 14:59:55 EDT
Same results.

Kernel param lines acpi_backlight=vendor xdriver=intel

Tried with and without acpi_backlight param.

Splash "F" screen is has no backlight, after that I have a script in the init sequence to turn on backlight.
Comment 13 Alexander Lomtev 2012-06-20 21:03:31 EDT
I have this problem on Fedora 17. Backlight works only with "acpi_osi=Linux acpi_backlight=vendor"  and manually  adding to the file /etc/rc.d/rc.local "echo 1589670 > /sys/class/backlight/intel_backlight/brightness"

uname -a:
Linux Emachines-E525 3.4.3-1.fc17.x86_64 #1 SMP Mon Jun 18 19:53:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Comment 14 Josh Boyer 2012-09-04 10:08:51 EDT
Is this still being seen with the 3.5 kernels in F17?
Comment 15 Brent R Brian 2012-09-04 11:30:26 EDT
I updated to latest code in repository.

Removed the kernel parms:
"xdriver=intel acpi_backlight=vendor".

Removed the rc2.d script with:
echo "400" > /sys/class/backlight/intel_backlight/brightness

She boots and backlight works from grub to desktop .. no issues.

Once I am logged in, the "ctrl <" and "ctrl >" display the info box and show the "intensity" bar ... but no change to intensity.

lsmod shows i915 driver.
Comment 16 Peter Scott 2012-10-23 10:02:51 EDT
*** Bug 771351 has been marked as a duplicate of this bug. ***
Comment 17 Peter Scott 2012-10-23 10:08:30 EDT
(In reply to comment #15)

> She boots and backlight works from grub to desktop .. no issues.

Are you sure? I used a different workround which periodically turns the backlight full on.

With a fully updated F17 the backlight still goes out during booting and stays off until my script turns it on.
Comment 18 Dave Jones 2012-10-23 11:32:45 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 19 Justin M. Forbes 2012-11-14 10:17:38 EST
With no response, we are closing this bug under the assumption that it is no longer an issue. If you still experience this bug, please feel free to reopen the bug report.
Comment 20 Brent R Brian 2012-11-14 12:56:04 EST
Duplicate of #753012?
Comment 21 Peter Scott 2012-11-16 08:14:32 EST
Please re-open this bug. It is still present in F17. I will provide whatever info is needed.