Bug 752835

Summary: Provide a way to keep/re-install firefox 3.6.x
Product: [Fedora] Fedora Reporter: Alain Knaff <buzrh>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 15CC: gecko-bugs-nobody, stransky
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-14 15:21:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alain Knaff 2011-11-10 14:44:45 UTC
Description of problem:

By default, yum update "up"grades all packages, including firefox, without any easy way to go back.

Version-Release number of selected component (if applicable):
7.0.1

How reproducible:

always

Steps to Reproduce:
1. yum upgrade
  
Actual results:

It blindly performs controversial "upgrades" as well as non-controversial ones, resulting in broken add-ons.

Expected results:

It should warn about controversial upgrades (such as Firefox, KDE4, Gnome shell, or whatever other "usability nightmare du jour" ...), and give the user the possibility to opt out of those, and a possibility to go back if he missed one of those.

Additional info:

Comment 1 Martin Stransky 2011-11-22 17:28:10 UTC
I guess you want this feature for yum, not for Firefox itself, right?

Comment 2 Alain Knaff 2011-11-22 19:43:30 UTC
I'm not sure which component (yum or firefox itself) would be responsible for this. I guess, at the very least, a 3.6.x version of firefox compatible with the current distribution release would need to be kept available in the repositories.

Comment 3 Martin Stransky 2012-02-14 15:21:36 UTC
For Firefox we follow the Mozilla policy, we ship what mozilla offers to linux users by default because Fedora is supposed to be "bleeding-edge" distribution. If you need something more conservative try Red Hat Enterprise Linux for instance (or some free variant).