Bug 753285

Summary: yum updates fails because of unsatisfied dependencies
Product: Red Hat Enterprise Linux 5 Reporter: serversupport.tosm
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED NOTABUG QA Contact: BaseOS QE Security Team <qe-baseos-security>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 5.7   
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-11-16 14:53:23 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description serversupport.tosm 2011-11-11 14:18:52 EST
Description of problem:The following output is near the bottom of the yum update output.

---> Package xorg-x11-server-Xorg.i386 0:1.1.1-48.76.el5_7.5 set to be updated
---> Package xorg-x11-server-Xvfb.i386 0:1.1.1-48.76.el5_7.5 set to be updated
---> Package xulrunner.i386 0:1.9.2.24-2.el5_7 set to be updated
--> Finished Dependency Resolution
apr-util-1.2.7-11.el5_5.2.i386 from installed has depsolving problems
  --> Missing Dependency: libpq.so.4 is needed by package apr-util-1.2.7-11.el5_5.2.i386 (installed)
perl-DBD-Pg-1.49-2.el5_3.1.i386 from installed has depsolving problems
  --> Missing Dependency: libpq.so.4 is needed by package perl-DBD-Pg-1.49-2.el5_3.1.i386 (installed)
--> Running transaction check
---> Package kernel.i686 0:2.6.18-238.12.1.el5 set to be erased
---> Package kernel-PAE.i686 0:2.6.18-238.12.1.el5 set to be erased
---> Package kernel-PAE-devel.i686 0:2.6.18-238.12.1.el5 set to be erased
--> Processing Dependency: libpq.so.4 for package: perl-DBD-Pg
--> Processing Dependency: libpq.so.4 for package: apr-util
--> Finished Dependency Resolution
apr-util-1.2.7-11.el5_5.2.i386 from installed has depsolving problems
  --> Missing Dependency: libpq.so.4 is needed by package apr-util-1.2.7-11.el5_5.2.i386 (installed)
perl-DBD-Pg-1.49-2.el5_3.1.i386 from installed has depsolving problems
  --> Missing Dependency: libpq.so.4 is needed by package perl-DBD-Pg-1.49-2.el5_3.1.i386 (installed)
Error: Missing Dependency: libpq.so.4 is needed by package apr-util-1.2.7-11.el5_5.2.i386 (installed)
Error: Missing Dependency: libpq.so.4 is needed by package perl-DBD-Pg-1.49-2.el5_3.1.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
--------------------------------------------------------------
When I tried to install libpq.so.4 I got this:

root@lib-esr1:/etc# yum install libpq.so.4
Loaded plugins: rhnplugin, security
Setting up Install Process
Package matching postgresql-libs-8.1.23-1.el5_7.2.i386 already installed. Checking for update.
Resolving Dependencies
--> Running transaction check
---> Package postgresql-libs.i386 0:8.1.23-1.el5_7.2 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================
 Package                   Arch           Version                     Repository                    Size
=========================================================================================================
Updating:
 postgresql-libs           i386           8.1.23-1.el5_7.2            rhel-i386-server-5           197 k

Transaction Summary
=========================================================================================================
Install       0 Package(s)
Upgrade       1 Package(s)

Total download size: 197 k
Is this ok [y/N]: y
Downloading Packages:
postgresql-libs-8.1.23-1.el5_7.2.i386.rpm                                         | 197 kB     00:00
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
postgresql-libs is needed by (installed) postgresql-8.4.9-1PGDG.rhel5.i386
postgresql-libs is needed by (installed) postgresql-8.4.9-1PGDG.rhel5.i386
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])
-------------------
The package-cleanup --problems and -- dups followed by rpm -Va --nofiles--nodigest is show below:
root@lib-esr1:/etc#  package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package mod_ssl requires httpd = 0:2.2.3-53.el5
Package mod_ssl requires httpd = 0:2.2.3-45.el5_6.1
root@lib-esr1:/etc# package-cleanup --dupes
Setting up yum
1:mod_ssl-2.2.3-45.el5_6.1.i386
1:mod_ssl-2.2.3-53.el5_7.1.i386
1:mod_ssl-2.2.3-53.el5.i386
postgresql-libs-8.1.23-1.el5_6.1.i386
postgresql-libs-8.4.9-1PGDG.rhel5.i386
root@lib-esr1:/etc# rpm -Va --nofiles --nodigest
Unsatisfied dependencies for java-1.5.0-sun-uninstall-1.5.0.22-1jpp.3.el5.i586: java-1.5.0-sun-plugin <= 0:1.5.0.22-1jpp.3.el5
Unsatisfied dependencies for mod_ssl-2.2.3-45.el5_6.1.i386: httpd = 0:2.2.3-45.el5_6.1
Unsatisfied dependencies for java-1.5.0-sun-uninstall-1.5.0.22-1jpp.3.el5.i586: java-1.5.0-sun <= 0:1.5.0.22-1jpp.3.el5
Unsatisfied dependencies for java-1.5.0-sun-uninstall-1.5.0.22-1jpp.3.el5.i586: java-1.5.0-sun <= 0:1.5.0.22-1jpp.3.el5, java-1.5.0-sun-devel <= 0:1.5.0.22-1jpp.3.el5, java-1.5.0-sun-plugin <= 0:1.5.0.22-1jpp.3.el5
/var/tmp/rpm-tmp.66401: line 851: IntegrateWithGNOME: command not found
Unsatisfied dependencies for java-1.5.0-sun-uninstall-1.5.0.22-1jpp.3.el5.i586: java-1.5.0-sun-devel <= 0:1.5.0.22-1jpp.3.el5
Unsatisfied dependencies for mod_ssl-2.2.3-53.el5.i386: httpd = 0:2.2.3-53.el5
------------------
But that did not fix yum update. I got the same error as before. 

Version-Release number of selected component (if applicable):
root@lib-esr1:/etc# yum list |grep yum
yum.noarch                             3.2.22-37.el5         installed
yum-metadata-parser.i386               1.1.2-3.el5           installed
yum-rhn-plugin.noarch                  0.5.4-22.el5_7.2      installed
yum-security.noarch                    1.1.16-16.el5         installed
yum-updatesd.noarch                    1:0.9-2.el5           installed
yum-utils.noarch                       1.1.16-16.el5         installed
yum-NetworkManager-dispatcher.noarch   1.1.16-16.el5         rhel-i386-server-5
yum-aliases.noarch                     1.1.16-16.el5         rhel-i386-server-5
yum-basearchonly.noarch                1.1.10-9.el5          rhel-i386-server-5
yum-changelog.noarch                   1.1.16-16.el5         rhel-i386-server-5
yum-downloadonly.noarch                1.1.16-16.el5         rhel-i386-server-5
yum-fastestmirror.noarch               1.1.16-16.el5         rhel-i386-server-5
yum-filter-data.noarch                 1.1.16-16.el5         rhel-i386-server-5
yum-keys.noarch                        1.1.16-16.el5         rhel-i386-server-5
yum-kmod.noarch                        1.1.16-16.el5         rhel-i386-server-5
yum-list-data.noarch                   1.1.16-16.el5         rhel-i386-server-5
yum-priorities.noarch                  1.1.16-16.el5         rhel-i386-server-5
yum-protect-packages.noarch            1.1.16-16.el5         rhel-i386-server-5
yum-protectbase.noarch                 1.1.16-16.el5         rhel-i386-server-5
yum-skip-broken.noarch                 1.1.10-9.el5          rhel-i386-server-5
yum-tmprepo.noarch                     1.1.16-16.el5         rhel-i386-server-5
yum-updateonboot.noarch                1.1.16-16.el5         rhel-i386-server-5
yum-verify.noarch                      1.1.16-16.el5         rhel-i386-server-5
yum-versionlock.noarch                 1.1.16-16.el5         rhel-i386-server-5


How reproducible:


Steps to Reproduce:
1. Issue the yum update command
2.
3.
  
Actual results:
See above

Expected results:
updates to work. 

Additional info:
Comment 1 James Antill 2011-11-16 14:53:23 EST
This is the problem:

# package-cleanup --dupes
Setting up yum
[...]
postgresql-libs-8.1.23-1.el5_6.1.i386
postgresql-libs-8.4.9-1PGDG.rhel5.i386

...this is confusing yum/rpm, as you can't have two versions of the same package installed and it work well.
 I'd recommend that you "yum remove" one of them, and then (to be safe) "yum reinstall" the one you kept. Then updates should work, as will the install (if you want to do that).