This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 753437

Summary: Incompatibility with Windows XP KVM from fedora 15 host
Product: [Fedora] Fedora Reporter: Tom Horsley <horsley1953>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: amit.shah, berrange, crobinso, dougsland, dwmw2, ehabkost, itamar, jaswinder, jforbes, knoel, scottt.tw, tburke, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-10 06:33:19 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
winxppro.xml virtual machine definition from fedora 15
none
xml definition for same machine after running on fedora 16 none

Description Tom Horsley 2011-11-12 09:00:57 EST
Description of problem:

I just tried moving my KVM definitions from my fedora 15 boot partition to
my newly installed fedora 16 system. I had been using spice and qxl on
fedora 15, but now on fedora 16, Windows XP thinks the hardware has changed
and wants a new VGA driver. I thought things were supposed to be upward
compatible inside the virtual machines?

Version-Release number of selected component (if applicable):

On fedora 16:
qemu-kvm-0.15.1-2.fc16.x86_64
qemu-system-x86-0.15.1-2.fc16.x86_64
qemu-common-0.15.1-2.fc16.x86_64
qemu-img-0.15.1-2.fc16.x86_64
gpxe-roms-qemu-1.0.1-4.fc16.noarch
libvirt-python-0.9.6-2.fc16.x86_64
libvirt-0.9.6-2.fc16.x86_64
libvirt-client-0.9.6-2.fc16.x86_64

On fedora 15 where KVM was running:
qemu-img-0.14.0-8.fc15.x86_64
qemu-kvm-0.14.0-8.fc15.x86_64
qemu-system-x86-0.14.0-8.fc15.x86_64
qemu-common-0.14.0-8.fc15.x86_64
libvirt-0.8.8-7.fc15.x86_64

How reproducible:
I only tried booting the KVM once, but I assume it would popup the
new hardware wizard any time I tried.

Steps to Reproduce:
1.cd /etc/libvirt/qemu 
2.cp /fedora15/etc/libvirt/qemu/*.xml .
3.service libvirtd restart
4.Boot a Windows XP virtual machine and watch it ask for new hardware
  
Actual results:
New hardware wizard in Windows XP virtual machine

Expected results:
Windows XP virtual machine doesn't realize anything has happened.

Additional info:
Comment 1 Tom Horsley 2011-11-12 09:04:10 EST
Created attachment 533251 [details]
winxppro.xml virtual machine definition from fedora 15
Comment 2 Tom Horsley 2011-11-12 10:06:03 EST
Also, the Windows XP virtual machine currently has the following display
driver installed:

Red Hat QXL GPU version 1.4.1.0 (9/29/2010)
Comment 3 Tom Horsley 2011-11-12 10:47:30 EST
After poking around a while, I downloaded the updated qxl driver from

http://spice-space.org/download/binaries/qxl-0.10-20112808.zip

into the Windows XP machine and told it to find the new driver in the
32 bit XP subdirectory from unpacking that file, and it seems to run
OK on fedora 16 now (also had to set the screen resolution back to normal
since it dropped down to 800x600 when it thought the display changed).

Even better, the same virtual machine image still runs OK under fedora 15,
so I guess everything is OK now, but I still wish it was able to transparently
run the same VMs when I upgrade the host.
Comment 4 Tom Horsley 2011-11-13 00:05:17 EST
And another incompatibility: I just realized my virtual machines were
awful quiet, and when I checked sound properties, it said there were
no sound devices configured, yet the VM had the ac97 audio device in
fedora 15.

I had to go into device manager and have it rescan the system for
hardware changes for the ac97 device to appear and the VM to start
making sounds.
Comment 5 Avi Kivity 2011-11-13 09:43:32 EST
What machine type does the guest xml say it is?
Comment 6 Tom Horsley 2011-11-13 09:57:47 EST
Created attachment 533378 [details]
xml definition for same machine after running on fedora 16
Comment 7 Tom Horsley 2011-11-13 09:59:11 EST
I've added the xml for the fedora 16 version of the same machine, both
the 15 and 14 say pc-0.14.
Comment 8 Tom Horsley 2011-11-13 11:35:22 EST
(In reply to comment #4)
> And another incompatibility: I just realized my virtual machines were
> awful quiet, and when I checked sound properties, it said there were
> no sound devices configured, yet the VM had the ac97 audio device in
> fedora 15.

This may be a false alarm (or some kind of timing issue).

I tried to reproduce it by starting from a new image with the
same backing file, and the ac97 device was found when I booted
the new image. I guess time will tell if it is sometimes there
and sometimes not there.
Comment 9 Justin M. Forbes 2011-11-15 10:56:37 EST
I believe we have an answer for the qxl portion which will make the next release.  I am curious though about the AC97 device.  Please give us an update after a bit of use.
Comment 10 Tom Horsley 2011-11-15 12:03:10 EST
I've booted the KVM several times now since the initial ac97 report above,
and haven't seen ac97 fail again, so if it is an intermittent problem of
some kind it appears to be very rare.
Comment 11 Fedora Admin XMLRPC Client 2012-03-15 13:57:29 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Cole Robinson 2012-07-10 06:33:19 EDT
Sounds like this should be fixed in current F16, if not please reopen and we can go from there.