This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 753681

Summary: Fedora 16 release installation fails to boot.
Product: [Fedora] Fedora Reporter: Peter Glassenbury <pete>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: anaconda-maint-list, dennis, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Other   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-11-30 10:20:51 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
anaconda-ks.cfg file for the quad core intel machine
none
/root/anaconda-ks.cfg
none
/root/install.log
none
/root/install.log.syslog
none
/var/log/anaconda.ifcfg.log
none
/var/log/anaconda.log
none
/var/log/anaconda.program.log
none
/var/log/anaconda.storage.log
none
/var/log/anaconda.syslog
none
/var/log/anaconda.xlog
none
/var/log/anaconda.yum.log
none
/var/log/dracut.log none

Description Peter Glassenbury 2011-11-14 00:26:49 EST
Created attachment 533432 [details]
anaconda-ks.cfg file for the quad core intel machine

Description of problem:
Installing Fedora 16 from DVD installs with no screen errors but fails to reboot

Version-Release number of selected component (if applicable):
Fedora-16-x86_64-DVD.iso from the local mirror.

How reproducible: every time.. two different machine motherboards core2 and quad-core intel machines.


Steps to Reproduce:
1. burn iso to DVD
2. boot, media check, and install from DVD
2a. click all defaults except make New install and replace everything on disk
    rather than save anything
3. tried selecting all software(customize); also tried just "Graphical Desktop"
  
Actual results:
installs fine; ejects DVD ; a reboot fails to find the disk and does not boot.

Expected results:
Boot into fedora.

Additional info:
Have booted into rescue mode and the the installation is there.
Attached the anaconda-ks.cfg from the quad core machine
have an error at the end of install.log which says..
"grubby fatal error: unable to find a suitable template"
Have googled and tried various attempts for grub2 fixes to no avail but
I would like to know what further information to submit to find and fix this in a more logical way... The google guess didn't work :-)
Comment 1 Peter Glassenbury 2011-11-15 23:13:13 EST
Hardware  in case it could be hardware compatibility is as follows... Not likely as worked fine on F14

motherboard      INTEL DQ45CB VPRO UATX DUAL DVI DX10 MOT
cpu              INTEL C2Q 8400 2.66GHZ 4M 1333MHZ NO VT
memory           8GB 800MHZ DDR2 NON-ECC CL6 DIMM
video(nvidia chip) GIGABYTE 9800GT1GB PCIE HDMI+DVI+VGA SIL
Disk             WD 250GB SE 7200RPM 16MB SATAII
dvd player       SONY AD7240SGB OEM DL SATA DVD±RW/RAM
Comment 2 Peter Glassenbury 2011-11-20 21:46:23 EST
This has me at a complete halt at the moment. Is there any progress. I have tried a network kickstart install with an anaconda.cfg but it has resulted in the same problem.
Comment 3 Peter Glassenbury 2011-11-21 20:39:28 EST
Some progress with diagnostics. On the Bios boot flash screen where it says enter F2 to enter Bios or F10 to boot, 
If I select F10 I get to a grub screen(grub version 1.99)
where I am asked to select from Fedora 3.1.1-2.f16-x86_64 and Fedora(recovery mode). I tried editing the line to see what it said but it asked for a usercode/ password and root couldn't get in. (?what usercode/password to use).
 Booting to Fedora failed to do anything useful the first time
 Booting to Fedora 16 recovery mode booted... and I was able to look around and 
tried to do grub2-setup and grub2-install. 

Booting to Fedora via this way(via the bios selection and  grub menu) worked this time BUT ONLY THIS WAY.. a normal boot still fails to find disk.

This is a lot lower level than my knowledge goes (usually starts from anaconda.cfg up :-)

Any help or pointers in what to look at?
Still a bug ... as the Release DVD doesn't produce a working system from its default settings.
Comment 4 Peter Glassenbury 2011-11-22 16:07:13 EST
Further progress... The disk was set in the BIOS to be pretend to be IDE..It seems to still be the default for our machines even for the modern ones of last year.
 Have changed it to be AHCI in "Disk configuration" in the BIOS. Now the install seems to work! Have still to try it on the other test machines, but at least one system is progressing. If anyone is looking at this bug yet, it would be nice to find out via an error message than by guessing. (if possible).
Comment 5 Peter Glassenbury 2011-11-28 18:58:29 EST
Further progress has been halted... need help here. 

Summary
All 4 machine types that we want to install have been updated to the latest BIOS on each type.
All 4 machine types have attempted a DVD install that use "use all space" on the
partitioning and defaults for everything else.
None of them will reboot after the install is completed. The disk cannot be found.
No linux error... it doesn't get as far as the grub menu selection.


An Aside comment:
While updating the BIOS with a windows USB, had a windows partition magic exe.
Since nothing was working, we tried running that "to see what was on the partition". We got errors. Since we didn't have a working system, we said yes to 
the "fix the partition".. to see what it would do. We could then boot from the disk to as far as grub and select a fedora to boot... but selecting a kernel to boot failed further on-- not surprising as we had played with the partitions...
It does point to the disk not being left in a bootable state after a DVD install.

BTW.. This is all working towards getting a sample working system so we can 
network kickstart all our machines in our department... upward of 300 odd.

Not sure what to try next.
Comment 6 Brian Lane 2011-11-28 20:12:50 EST
Please switch to tty2 (ctrl-alt-f2) and attach the logs from /tmp/*log to this bug as individual plain/text files.
Comment 7 Peter Glassenbury 2011-11-28 21:22:47 EST
At the end of install I don't get a login to do a ctrl-alt-f2.
I have booted from the rescue disk and gone into /mnt/sysimage and there
are no files in /tmp .. ( I thought they were moved to /root and /var/tmp/anaconda at the end of the install). I have included all the anaconda files I could see.. (renaming them to have Root and VarTmp in front of the name so know where they came from)... attached
Comment 8 Peter Glassenbury 2011-11-28 21:24:42 EST
Created attachment 537723 [details]
/root/anaconda-ks.cfg
Comment 9 Peter Glassenbury 2011-11-28 21:25:19 EST
Created attachment 537724 [details]
/root/install.log
Comment 10 Peter Glassenbury 2011-11-28 21:25:56 EST
Created attachment 537725 [details]
/root/install.log.syslog
Comment 11 Peter Glassenbury 2011-11-28 21:26:46 EST
Created attachment 537726 [details]
/var/log/anaconda.ifcfg.log
Comment 12 Peter Glassenbury 2011-11-28 21:27:18 EST
Created attachment 537727 [details]
/var/log/anaconda.log
Comment 13 Peter Glassenbury 2011-11-28 21:27:55 EST
Created attachment 537729 [details]
/var/log/anaconda.program.log
Comment 14 Peter Glassenbury 2011-11-28 21:28:26 EST
Created attachment 537730 [details]
/var/log/anaconda.storage.log
Comment 15 Peter Glassenbury 2011-11-28 21:29:13 EST
Created attachment 537731 [details]
/var/log/anaconda.syslog
Comment 16 Peter Glassenbury 2011-11-28 21:29:51 EST
Created attachment 537732 [details]
/var/log/anaconda.xlog
Comment 17 Peter Glassenbury 2011-11-28 21:30:28 EST
Created attachment 537733 [details]
/var/log/anaconda.yum.log
Comment 18 Peter Glassenbury 2011-11-28 21:31:01 EST
Created attachment 537735 [details]
/var/log/dracut.log
Comment 19 Brian Lane 2011-11-29 12:37:13 EST
The logs look good. It completed the install and grub2 didn't throw any errors. Fedora 16 uses GPT labels on the disk and we have found some system have trouble booting from GPT. If you pass nogpt on the cmdline when booting the install media it will use a msdos label on the disk instead of GPT. Could you give that a try and see if it boots?
Comment 20 Peter Glassenbury 2011-11-29 23:51:02 EST
Progress. The nogpt when booting this appears to work.. Tested on two hardware platforms. How do I put this into a kickstart file? 
 "nogpt" on a line by itself underneath "install" line in a kickstart file doesn't work.

The nogpt option didn't appear in the sample /root/anaconda.cfg 
from the DVD install.
Comment 21 Brian Lane 2011-11-30 10:20:51 EST
Cool. Currently nogpt is only a cmdline option, not a kickstart command so you will have to add it to the cmdline along with your kickstart.
Comment 22 Peter Glassenbury 2011-12-11 18:27:49 EST
Have tested the various boards (sorry it took a while) and have a summary of
what happened and what will break things critically... Not sure if a new bug 
required..
In the BIOS we could define the sata disks as IDE or AHCI

SUMMARY .. installing a ..
-- default F16 (GPT, IDE disk) produced a machine which failed to find disk.
-- default F16 (GPT, AHCI disk) worked on later machines but NOT Intel DQ35JOE
         core 2 duo and quad core boards (2008/9 vintage)
-- default F16 (nogpt, AHCI) produced a Intel DQ35JOE machine that would fail 
         POST !!! and get an error on AHCI controller... needed to unplug the 
         hard drive. Then could boot into the BIOS change the disk setting to IDE
         and the install would continue (This with the latest BIOS version)
-- default F16 (nogpt, IDE) works on all machines ... but of course is
         a slower boot :-)