Bug 754388

Summary: Provide native systemd service
Product: [Fedora] Fedora Reporter: Jóhann B. Guðmundsson <johannbg>
Component: anytermAssignee: Alexander Boström <abo>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: abo, gwync
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-01 22:54:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 751869    
Attachments:
Description Flags
Native systemd unit for anyterm none

Description Jóhann B. Guðmundsson 2011-11-16 10:56:54 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2011-11-16 11:09:24 UTC
Created attachment 533977 [details]
Native systemd unit for anyterm

Note this daemon seems to be utterley broken and does not create pid file as upstream indicates it should thus systemd complains about the missing pid file thus this unit runs as type oneshot not forking.

Comment 2 Alexander Boström 2011-11-19 10:51:00 UTC
Thanks, I'll test and apply it. Hoping to actually fix the deamon too.

Comment 3 Gwyn Ciesla 2012-05-11 14:59:30 UTC
Alexander, any plans to commit this?  If not, do you mind if I do?

Comment 4 Alexander Boström 2012-05-22 13:58:55 UTC
> does not create pid file

It only creates a pid file when started as root.

This deamon would typically run on a host with multiple users of various trust level so it needs a priviledged port and thus sadly needs to start as root. (Yes, even better would be to use socket activation.)

I'll adapt and commit it, along with some other changes.

Comment 5 Alexander Boström 2012-06-01 22:54:01 UTC
Committed.

Comment 6 Gwyn Ciesla 2012-06-04 13:22:06 UTC
Thank you!