Bug 755255

Summary: atl1c WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0xf0/0x150()
Product: [Fedora] Fedora Reporter: Tom Horsley <horsley1953>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-11-20 10:16:41 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
The output from dmesg none

Description Tom Horsley 2011-11-19 22:57:43 EST
Description of problem:

I get the following kernel traceback in my logs when I boot my fedora 16
system. It looks similar to other bugs I see in the database on fedora 15
with different NICs and different kernels, but it seems different enough
to go ahead and report separately:

Nov 19 22:41:55 zooty kernel: [   10.921250] atl1c 0000:06:00.0: atl1c: p6p1 NIC Link is Up<1000 Mbps Full Duplex>
Nov 19 22:41:55 zooty kernel: [   10.921723] ADDRCONF(NETDEV_CHANGE): p6p1: link becomes ready
Nov 19 22:41:55 zooty kernel: [   10.921795] br0: port 1(p6p1) entering forwarding state
Nov 19 22:41:55 zooty kernel: [   10.921799] br0: port 1(p6p1) entering forwarding state
Nov 19 22:41:55 zooty kernel: [   10.922431] ADDRCONF(NETDEV_CHANGE): br0: link becomes ready
Nov 19 22:41:56 zooty ntpd[884]: Listen normally on 4 br0 192.168.1.106 UDP 123
Nov 19 22:41:56 zooty ntpd[884]: peers refreshed
Nov 19 22:41:56 zooty kernel: [   11.835521] atl1c 0000:06:00.0: atl1c: p6p1 NIC Link is Down
Nov 19 22:41:56 zooty kernel: [   11.918788] br0: port 1(p6p1) entering forwarding state
Nov 19 22:41:59 zooty ntpd[884]: Listen normally on 5 br0 fe80::16da:e9ff:fe72:9e22 UDP 123
Nov 19 22:41:59 zooty ntpd[884]: Listen normally on 6 p6p1 fe80::16da:e9ff:fe72:9e22 UDP 123
Nov 19 22:41:59 zooty ntpd[884]: peers refreshed
Nov 19 22:41:59 zooty kernel: [   14.851899] atl1c 0000:06:00.0: atl1c: p6p1 NIC Link is Up<1000 Mbps Full Duplex>
Nov 19 22:41:59 zooty kernel: [   14.852368] br0: port 1(p6p1) entering forwarding state
Nov 19 22:41:59 zooty kernel: [   14.852374] br0: port 1(p6p1) entering forwarding state
Nov 19 22:42:04 zooty kernel: [   19.897852] ------------[ cut here ]------------
Nov 19 22:42:04 zooty kernel: [   19.897860] WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0xf0/0x150()
Nov 19 22:42:04 zooty kernel: [   19.897862] Hardware name: System Product Name
Nov 19 22:42:04 zooty kernel: [   19.897863] NETDEV WATCHDOG: p6p1 (atl1c): transmit queue 0 timed out
Nov 19 22:42:04 zooty kernel: [   19.897865] Modules linked in: ppdev parport_pc lp parport bridge stp llc w83627ehf hwmon_vid coretemp ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_realtek joydev usblp usb_storage uas eeepc_wmi asus_wmi sparse_keymap rfkill snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm virtio_net kvm_intel microcode kvm serio_raw i2c_i801 iTCO_wdt atl1c iTCO_vendor_support snd_timer snd soundcore snd_page_alloc uinput nfsd lockd nfs_acl auth_rpcgss sunrpc wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
Nov 19 22:42:04 zooty kernel: [   19.897902] Pid: 0, comm: swapper Not tainted 3.1.1-2.fc16.x86_64 #1
Nov 19 22:42:04 zooty kernel: [   19.897904] Call Trace:
Nov 19 22:42:04 zooty kernel: [   19.897905]  <IRQ>  [<ffffffff81057a1e>] warn_slowpath_common+0x83/0x9b
Nov 19 22:42:04 zooty kernel: [   19.897911]  [<ffffffff81057ad9>] warn_slowpath_fmt+0x46/0x48
Nov 19 22:42:04 zooty kernel: [   19.897914]  [<ffffffff813f0945>] ? netif_tx_lock+0x4a/0x7c
Nov 19 22:42:04 zooty kernel: [   19.897918]  [<ffffffff813f0abb>] dev_watchdog+0xf0/0x150
Nov 19 22:42:04 zooty kernel: [   19.897921]  [<ffffffff81064b19>] run_timer_softirq+0x19b/0x280
Nov 19 22:42:04 zooty kernel: [   19.897925]  [<ffffffff81014b35>] ? paravirt_read_tsc+0x9/0xd
Nov 19 22:42:04 zooty kernel: [   19.897927]  [<ffffffff813f09cb>] ? netif_tx_unlock+0x54/0x54
Nov 19 22:42:04 zooty kernel: [   19.897931]  [<ffffffff8105d67b>] __do_softirq+0xc9/0x1b5
Nov 19 22:42:04 zooty kernel: [   19.897934]  [<ffffffff81014b35>] ? paravirt_read_tsc+0x9/0xd
Nov 19 22:42:04 zooty kernel: [   19.897938]  [<ffffffff814bfb6c>] call_softirq+0x1c/0x30
Nov 19 22:42:04 zooty kernel: [   19.897942]  [<ffffffff81010b45>] do_softirq+0x46/0x81
Nov 19 22:42:04 zooty kernel: [   19.897944]  [<ffffffff8105d943>] irq_exit+0x57/0xb1
Nov 19 22:42:04 zooty kernel: [   19.897947]  [<ffffffff814c04e1>] smp_apic_timer_interrupt+0x7c/0x8a
Nov 19 22:42:04 zooty kernel: [   19.897950]  [<ffffffff814be3de>] apic_timer_interrupt+0x6e/0x80
Nov 19 22:42:04 zooty kernel: [   19.897951]  <EOI>  [<ffffffff81014b35>] ? paravirt_read_tsc+0x9/0xd
Nov 19 22:42:04 zooty kernel: [   19.897957]  [<ffffffff8126974c>] ? intel_idle+0xd8/0x100
Nov 19 22:42:04 zooty kernel: [   19.897960]  [<ffffffff8126972e>] ? intel_idle+0xba/0x100
Nov 19 22:42:04 zooty kernel: [   19.897964]  [<ffffffff813a5fce>] cpuidle_idle_call+0xe8/0x182
Nov 19 22:42:04 zooty kernel: [   19.897967]  [<ffffffff8100e2e3>] cpu_idle+0xa4/0xe8
Nov 19 22:42:04 zooty kernel: [   19.897971]  [<ffffffff81494a7e>] rest_init+0x72/0x74
Nov 19 22:42:04 zooty kernel: [   19.897974]  [<ffffffff81b76b7d>] start_kernel+0x3ab/0x3b6
Nov 19 22:42:04 zooty kernel: [   19.897977]  [<ffffffff81b762c4>] x86_64_start_reservations+0xaf/0xb3
Nov 19 22:42:04 zooty kernel: [   19.897979]  [<ffffffff81b76140>] ? early_idt_handlers+0x140/0x140
Nov 19 22:42:04 zooty kernel: [   19.897982]  [<ffffffff81b763ca>] x86_64_start_kernel+0x102/0x111
Nov 19 22:42:04 zooty kernel: [   19.897984] ---[ end trace 35737fde485109cb ]---
Nov 19 22:42:04 zooty kernel: [   19.898804] br0: port 1(p6p1) entering forwarding state
Nov 19 22:42:04 zooty kernel: [   19.911662] atl1c 0000:06:00.0: atl1c: p6p1 NIC Link is Up<1000 Mbps Full Duplex>
Nov 19 22:42:04 zooty kernel: [   19.912146] br0: port 1(p6p1) entering forwarding state
Nov 19 22:42:04 zooty kernel: [   19.912151] br0: port 1(p6p1) entering forwarding state

I don't see any obvious system problems as a result of this, and I think it
only happens once at boot time.

My motherboard is ASUS P8H67-V (REV 3.0) LGA 1155 Intel H67

Version-Release number of selected component (if applicable):
kernel-3.1.1-2.fc16.x86_64


How reproducible:
Every time I boot

Steps to Reproduce:
1.boot system
2.look in /var/log/messages
3.
  
Actual results:
error

Expected results:
no error

Additional info:
Comment 1 Tom Horsley 2011-11-19 22:59:34 EST
Created attachment 534621 [details]
The output from dmesg
Comment 2 Josh Boyer 2011-11-20 10:16:41 EST

*** This bug has been marked as a duplicate of bug 717211 ***