Bug 756499

Summary: [abrt] xen-4.1.2-1.fc16: image.py:46:<module>:Error: (1, 'Internal error', 'xc_interface_open failed: Permission denied')
Product: [Fedora] Fedora Reporter: Joan Aymà <joanayma>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: berrange, jforbes, kraxel, m.a.young, virt-maint, xen-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:7b3e98c5f19a39d97b36c2aff3e9bc6b3b27428a
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-04 16:21:00 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
File: smolt_data
File: backtrace none

Description Joan Aymà 2011-11-23 14:16:42 EST
libreport version: 2.0.7
cmdline:        /usr/bin/python /usr/sbin/xend status
comment:        Happens when selinux is in Enforcing mode and you authenticate on policykit, executing virt-manager.
executable:     /usr/sbin/xend
kernel:         3.1.1-1.fc16.x86_64
reason:         image.py:46:<module>:Error: (1, 'Internal error', 'xc_interface_open failed: Permission denied')
time:           dc 16 nov 2011 23:51:11 CET
uid:            1000
username:       joan

backtrace:      Text file, 9840 bytes
smolt_data:     Text file, 4589 bytes
Comment 1 Joan Aymà 2011-11-23 14:16:48 EST
Created attachment 535596 [details]
File: smolt_data
Comment 2 Joan Aymà 2011-11-23 14:16:50 EST
Created attachment 535597 [details]
File: backtrace
Comment 3 Michael Young 2011-11-23 15:14:13 EST
What happens if you make selinux permissive first ie. run setenforce 0 beforehand?
Comment 4 Joan Aymà 2011-11-27 17:26:27 EST
I tried first with #setenforce 0 and after set selinux permissive on config files. Same result.
I saw that is not releated to only when I authenticate to libvirtd neither to selinux, oposite to what I think first, and anything seams to crash. Just this weird bug report. 

I can't get a scenerio for this bug but it appears often. Maybe I should ask on forums first? Or could be a false positive? I'm too new to bug reporting.
Comment 5 Michael Young 2011-12-04 16:21:00 EST

*** This bug has been marked as a duplicate of bug 742699 ***