Bug 7583

Summary: mod_php3 and mod_perl don't run together in default install
Product: [Retired] Red Hat Secure Web Server Reporter: weave
Component: mod_php3Assignee: Preston Brown <pbrown>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-13 15:46:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description weave 1999-12-04 16:55:20 UTC
First of all, this is for secureweb-3.1-1 as shipped with RH 6.1 Prof.

I tried enabling both mod_perl and mod_php3 by uncommenting entries in
httpd.conf.  The server started and quickly died with no error messages,
nor any log entries.

Believe it or not, changing the order of how the modules load in httpd.conf
so mod_php3 loads BEFORE mod_perl fixed it

Comment 1 Preston Brown 2000-01-13 15:46:59 UTC
I'm not sure what configuration file you are using, but I have just verified
that for Secure Web Server 3.1, mod_php3 is listed before mod_php in httpd.conf.