Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 75901

Summary: GUI installation provides an exception error at the beginning of package install
Product: [Retired] Red Hat Linux Reporter: Need Real Name <howievogel>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED WONTFIX QA Contact: Brock Organ <borgan>
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: michael
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-10-14 15:11:11 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2002-10-14 15:10:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
GUI installer works fine until actual package installation, then before any 
packages install I get an OSError: [Errno 12] Cannot allocate memory. Tried to 
install using manual mem=XXM but errored out in same place. Thought it was a 
FAT32 problem, blew away partition on drive, same result. Checked CD's for file 
defects and all came back without error. Autodiscovery of components works 
without problem. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install from CD.
2. Took defaults on everything
3. Exception error on beginning of package installation.
	

Actual Results:  Received an exception error: "OSError: [Errno 12] Cannot 
allocate memory"

Expected Results:  Installation should have continued.

Additional info:

The computer is a Compaq Presario 2240, 48MB RAM and 2GB hard disk.

File "usr/lib/anaconda/gui.py", line 786, in handleRenderCallback 
self.currentWindow.renderCallback()
File "usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback 
self.intf.icw.nextClicked()
File "usr/lib/anaconda/gui.py", line 632, in nextClicked self.dispatch.gotoNext
()
File "usr/lib/anaconda/dispatch.py", line 150, in gotoNext self.moveStep()
File "usr/lib/anaconda/dispatch.py", line 215, in moveStep rc=applyfunc, 
self.bindArgs(args))
File "usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems 
partitions.doMetaDeletes(diskset)
File "usr/lib/anaconda/partitions.py", line 1110, in doMetaDeletes 
lvm.vgactivate()
File "usr/lib/anaconda/lvm.py", line 54, in vgactivate searchPath=1)
File "usr/lib/anaconda/iutil.py", line 66, in execWithRedirect childpid=os.fork
()
OSError: [Errno 12] Cannot allocate memory
Comment 1 Jeremy Katz 2002-10-16 17:54:33 EDT
GUI installs probably don't work without 64 megs of RAM these days -- we don't
even technically support installs with < 64 megs of RAM, but a text-mode NFS or
CD-ROM install should work fine with 48.
Comment 2 Need Real Name 2002-10-19 15:26:31 EDT
this is a duplicate of 74847
Comment 3 Michael Lee Yohe 2003-01-09 09:09:59 EST
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M+ of memory and 128M of
swap.  

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.  Anaconda, in
text mode, is more lenient on memory resources.