Bug 762463 (GLUSTER-731)

Summary: Fio write test for 1TB of data fails
Product: [Community] GlusterFS Reporter: Anush Shetty <anush>
Component: nfsAssignee: Shehjar Tikoo <shehjart>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: nfs-alphaCC: gluster-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: RTNR Mount Type: nfs
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Anush Shetty 2010-03-17 08:42:14 EDT
Setup: 2 replicated GlusterFS servers

fio config file:
[job1]
filename=/jbod/anush/client1/testfile
size=1024G
rw=write
bs=64K

Log:
patchset: git://git.sv.gnu.org/gluster.git
signal received: 11
time of crash: 2010-03-17 05:29:13
configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.0.0git
/lib64/libc.so.6[0x333da301b0]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/nfs/server.so(nfs3_call_state_wipe+0x22)[0x2b278fb84e22]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/nfs/server.so(nfs3svc_write_cbk+0xcd)[0x2b278fb874ed]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/nfs/server.so(nfs_fop_writev_cbk+0x9b)[0x2b278fb77f7b]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/cluster/replicate.so(afr_writev_unwind+0xd2)[0x2b278f943522]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/cluster/replicate.so(afr_writev_wind_cbk+0xba)[0x2b278f944e9a]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/protocol/client.so(client_write_cbk+0x289)[0x2b278f71eb69]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/protocol/client.so(protocol_client_pollin+0xca)[0x2b278f70b0ba]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/protocol/client.so(notify+0x212)[0x2b278f7124d2]
/opt/glusterfs/gnfs/lib/libglusterfs.so.0(xlator_notify+0x43)[0x2b278ec4a1c3]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/transport/socket.so(socket_event_handler+0xd3)[0x2aaaaab9a073]
/opt/glusterfs/gnfs/lib/libglusterfs.so.0[0x2b278ec63e35]
/opt/glusterfs/gnfs/sbin/glusterfs(main+0x9e8)[0x404118]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x333da1d8b4]
/opt/glusterfs/gnfs/sbin/glusterfs[0x4026b9]

bt:
#0  nfs3_call_state_wipe (cs=0x2aaaab0c27a0) at nfs3.c:195
#1  0x00002b278fb874ed in nfs3svc_write_cbk (frame=<value optimized out>, cookie=<value optimized out>, this=<value optimized out>, 
    op_ret=<value optimized out>, op_errno=0, prebuf=0x2aaaac102fe0, postbuf=0x2aaaac103070) at nfs3.c:1634
#2  0x00002b278fb77f7b in nfs_fop_writev_cbk (frame=0x2aaaac0cbbd8, cookie=0x650ff00, this=0x650ff00, op_ret=65536, op_errno=0, prebuf=0x2aaaac102fe0, 
    postbuf=0x2aaaac103070) at nfs-fops.c:1104
#3  0x00002b278f943522 in afr_writev_unwind (frame=<value optimized out>, this=<value optimized out>) at afr-inode-write.c:75
#4  0x00002b278f944e9a in afr_writev_wind_cbk (frame=0x2aaaac0e0348, cookie=<value optimized out>, this=0x650ff00, op_ret=65536, op_errno=0, 
    prebuf=0x7fff5ad162e0, postbuf=0x7fff5ad16250) at afr-inode-write.c:138
#5  0x00002b278f71eb69 in client_write_cbk (frame=0x656d850, hdr=<value optimized out>, hdrlen=<value optimized out>, iobuf=<value optimized out>)
    at client-protocol.c:4455
#6  0x00002b278f70b0ba in protocol_client_pollin (this=0x650ee40, trans=0x6513250) at client-protocol.c:6827
#7  0x00002b278f7124d2 in notify (this=0x2aaaac0cbaa0, event=2, data=0x6513250) at client-protocol.c:6946
#8  0x00002b278ec4a1c3 in ?? () from /opt/glusterfs/gnfs/lib/libglusterfs.so.0
#9  0x0000000006513250 in ?? ()
#10 0x0000000000000000 in ?? ()
Comment 1 Shehjar Tikoo 2010-03-17 22:31:08 EDT
Can I have the log please.
Comment 2 Shehjar Tikoo 2010-04-20 23:00:17 EDT

*** This bug has been marked as a duplicate of bug 757 ***