Bug 762731 (GLUSTER-999)

Summary: Crash in nfs3_fh_resolve_and_resume
Product: [Community] GlusterFS Reporter: Anush Shetty <anush>
Component: nfsAssignee: Shehjar Tikoo <shehjart>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: low    
Version: nfs-alphaCC: amarts, gluster-bugs, lakshmipathi, vijay
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: RTNR Mount Type: nfs
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
NFS server log none

Description Shehjar Tikoo 2010-06-11 07:16:27 EDT
I need the log please.
Comment 1 Anush Shetty 2010-06-11 08:45:14 EDT
Saw this crash in nfs-beta while running iozone 

Vol file:
volume posix1
  type storage/posix                    
  option directory /gluster/export1
end-volume

volume locks
  type features/posix-locks
  option mandatory on         
  subvolumes posix1
end-volume

volume brick1
 type performance/io-threads
 option thread-count 8
 subvolumes locks
end-volume

volume eg
 type debug/error-gen
 option failure 5
 subvolumes brick1
end-volume

volume nfs
 type nfs/server
 subvolumes eg
 option rpc-auth.addr.allow *
end-volume

patchset: git://git.sv.gnu.org/gluster.git
signal received: 11
time of crash: 2010-06-11 17:36:18
configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.0.0git
/lib/libc.so.6[0x7f74a9cdc530]
/gluster/nfsbeta/lib/glusterfs/3.0.0git/xlator/nfs/server.so(nfs3_fh_resolve_and_resume+0x5e)[0x7f74a8a4f2ae]
/gluster/nfsbeta/lib/glusterfs/3.0.0git/xlator/nfs/server.so(nfs3_write+0x37b)[0x7f74a8a4b84b]
/gluster/nfsbeta/lib/glusterfs/3.0.0git/xlator/nfs/server.so(nfs3svc_write_vec+0x89)[0x7f74a8a4bad9]
/gluster/nfsbeta/lib/libglrpcsvc.so.0(rpcsvc_record_vectored_call_actor+0x52)[0x7f74a881dcd2]
/gluster/nfsbeta/lib/libglrpcsvc.so.0(rpcsvc_update_vectored_state+0xb8)[0x7f74a881e4f8]
/gluster/nfsbeta/lib/libglrpcsvc.so.0(rpcsvc_record_update_state+0x121)[0x7f74a881e781]
/gluster/nfsbeta/lib/libglrpcsvc.so.0(rpcsvc_conn_data_handler+0x68)[0x7f74a881ead8]
/gluster/nfsbeta/lib/libglusterfs.so.0[0x7f74aa4698ad]
/gluster/nfsbeta/lib/libglrpcsvc.so.0(rpcsvc_stage_proc+0x12)[0x7f74a881ff82]
/lib/libpthread.so.0[0x7f74aa01ea04]
/lib/libc.so.6(clone+0x6d)[0x7f74a9d8880d]
Comment 2 Shehjar Tikoo 2010-06-15 03:47:13 EDT
The logs please?
Comment 3 Shehjar Tikoo 2010-07-04 03:00:27 EDT
Anush, we have been running tera bytes of IO using iozone over nfs so if I have to fix this, I need those logs which I've asked for before. This does not look like a trivial bug because of the extensive testing the IO path in NFS is undergoing.
Comment 4 Shehjar Tikoo 2010-07-04 03:17:39 EDT
The one thing you need to try for reproducing this is by using the access-control translator. Its not there in this volume file. Please test with and without access-control to reproduce. Just another data point in helping fix it.
Comment 5 Shehjar Tikoo 2010-07-29 03:41:46 EDT
Not able to reproduce. Closing.
Comment 6 Anush Shetty 2010-07-29 03:57:40 EDT
I still got the crash with Alpha. Works now with Beta git
Comment 7 Shehjar Tikoo 2010-09-24 03:40:42 EDT
User reported this on 3.1 qa27. Reopening.
Comment 8 Samuli Heinonen 2010-09-24 04:33:33 EDT
Created attachment 315


NFS server crashed during file copying.
Comment 9 Shehjar Tikoo 2010-10-05 04:25:14 EDT
*** Bug 1755 has been marked as a duplicate of this bug. ***
Comment 10 Vijay Bellur 2010-10-12 01:39:44 EDT
PATCH: http://patches.gluster.com/patch/5466 in master (nfs: avoid assignment of structure pointer into serialized buffer)
Comment 11 Amar Tumballi 2010-10-12 23:27:36 EDT
Issue fixed with http://patches.gluster.com/patch/5466/
Comment 12 Vijay Bellur 2010-10-18 23:25:13 EDT
*** Bug 1909 has been marked as a duplicate of this bug. ***
Comment 13 Shehjar Tikoo 2010-10-19 00:10:18 EDT
Thanks. thats a beautiful fix.