Bug 763247 (GLUSTER-1515)

Summary: 3.1.0 qa14 : unable to mount from client
Product: [Community] GlusterFS Reporter: Lakshmipathi G <lakshmipathi>
Component: glusterdAssignee: Csaba Henk <csaba>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: low    
Version: 3.1-alphaCC: anush, gluster-bugs, vijay
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: RTP Mount Type: fuse
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Lakshmipathi G 2010-09-03 01:16:06 EDT
client details - 
# uname -a
Linux ip-10-245-209-205 2.6.21.7-2.fc8xen #1 SMP Fri Feb 15 12:39:36 EST 2008 i686 i686 i386 GNU/Linux
Comment 1 Lakshmipathi G 2010-09-03 01:27:59 EDT
only fuse mount causes this issue,nfs mount works fine.
Comment 2 Anush Shetty 2010-09-03 02:27:54 EDT
The backtrace

patchset: git://git.sv.gnu.org/gluster.git
signal received: 11
time of crash: 2010-09-03 05:25:18
configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.1.0git
/lib64/libc.so.6[0x2aaaab7b4f30]
/usr/local/lib/libglusterfs.so.0(inode_ref+0x29)[0x2aaaaacf1371]
/usr/local/lib/glusterfs/3.1.0git/xlator/mount/fuse.so(fuse_ino_to_inode+0x5a)[0x2aaaac7fcac7]
/usr/local/lib/glusterfs/3.1.0git/xlator/mount/fuse.so(fuse_loc_fill+0x16a)[0x2aaaac7fcc6c]
/usr/local/lib/glusterfs/3.1.0git/xlator/mount/fuse.so[0x2aaaac8020e3]
/usr/local/lib/glusterfs/3.1.0git/xlator/mount/fuse.so[0x2aaaac8112d0]
/lib64/libpthread.so.0[0x2aaaab56f407]
/lib64/libc.so.6(clone+0x6d)[0x2aaaab858b0d]
Comment 3 Lakshmipathi G 2010-09-03 03:04:50 EDT
With 4 dht setup started,
#gluster volume start dht4
Starting volume dht4 has been successful
10.192.141.187#gluster volume info

Volume Name: dht4
Type: None
Status: Started
Number of Bricks: 4
Bricks:
Brick1: 10.192.134.144:/mnt/d1
Brick2: 10.214.231.112:/mnt/d1
Brick3: 10.198.110.16:/mnt/d1
Brick4: 10.192.141.187:/mnt/d1

while try to mount from client c1- mount succeeds,but df command hangs

ps shows two processes trying to fetch and mount  
# ps ax | grep gluster
  575 ?        Ssl    2:42 /old_opt/glusterfs/3.0.4/sbin/glusterfs --log-level=NORMAL --volfile=/root/cfg.vol /opt
29713 ?        Ssl    0:02 /usr/local/sbin/glusterfs --log-level=NORMAL --volfile-id=dht4 --volfile-server=10.192.141.187 /mnt
29719 ?        S      0:00 /usr/local/sbin/glusterfs --log-level=NORMAL --volfile-id=dht4 --volfile-server=10.192.141.187 /mnt
Comment 4 Lakshmipathi G 2010-09-03 06:35:11 EDT
tested with 3.1.0qa15 now fuse mount  works
Comment 5 Vijay Bellur 2010-09-03 09:56:37 EDT

*** This bug has been marked as a duplicate of bug 801 ***