This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 763350 (GLUSTER-1618)

Summary: glusterd crashed when volume create command issued without probing
Product: [Community] GlusterFS Reporter: Lakshmipathi G <lakshmipathi>
Component: glusterdAssignee: Vijay Bellur <vbellur>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 2.0.0CC: gluster-bugs, sgowda
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: RTP Mount Type: All
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Lakshmipathi G 2010-09-15 23:26:27 EDT
#bt  full
#1  0x0000003542631d10 in abort () from /lib64/libc.so.6
No symbol table info available.
#2  0x00000035426296e6 in __assert_fail () from /lib64/libc.so.6
No symbol table info available.
#3  0x00002aaaabecf6d7 in glusterd3_1_cluster_lock_cbk (req=0x2aaaafd4003c, iov=0x2aaaafd4007c, count=1, myframe=0x2aaaabbd01d8) at glusterd3_1-mops.c:411
        rsp = {uuid = "\303#'\363Q)F\273\215\374\270(X\020\266M", op_ret = 0, op_errno = 0}
        ret = -1
        op_ret = 0
        event_type = GD_OP_EVENT_NONE
        peerinfo = 0x0
        str = "c32327f3-5129-46bb-8dfc-b8285810b64d", '\000' <repeats 13 times>
        __PRETTY_FUNCTION__ = "glusterd3_1_cluster_lock_cbk"
        __FUNCTION__ = "glusterd3_1_cluster_lock_cbk"
#4  0x00002aaaaad2eee5 in rpc_clnt_handle_reply (clnt=0x662ef8, pollin=0x2aaab4002348) at rpc-clnt.c:737
        conn = 0x662f28
        saved_frame = 0x2aaaaff8503c
        ret = 0
        req = 0x2aaaafd4003c
        xid = 1
        __FUNCTION__ = "rpc_clnt_handle_reply"
#5  0x00002aaaaad2f220 in rpc_clnt_notify (trans=0x663118, mydata=0x662f28, event=RPC_TRANSPORT_MSG_RECEIVED, data=0x2aaab4002348) at rpc-clnt.c:850
        conn = 0x662f28
        clnt = 0x662ef8
        ret = -1
        req_info = 0x0
        pollin = 0x2aaab4002348
        tv = {tv_sec = 0, tv_usec = 0}
#6  0x00002aaaaad2caa5 in rpc_transport_notify (this=0x663118, event=RPC_TRANSPORT_MSG_RECEIVED, data=0x2aaab4002348) at rpc-transport.c:1134
        ret = -1
#7  0x00002aaaac181288 in socket_event_poll_in (this=0x663118) at socket.c:1579
        ret = 0
        pollin = 0x2aaab4002348
#8  0x00002aaaac1815f9 in socket_event_handler (fd=5, idx=6, data=0x663118, poll_in=1, poll_out=0, poll_err=0) at socket.c:1693
        this = 0x663118
        priv = 0x6635e8
        ret = 0
        __FUNCTION__ = "socket_event_handler"
#9  0x00002aaaaaaec8a4 in event_dispatch_epoll_handler (event_pool=0x62c168, events=0x66b498, i=0) at event.c:812
        event_data = 0x66b49c
        handler = 0x2aaaac1814fd <socket_event_handler>
        data = 0x663118
        idx = 6
        ret = -1
        __FUNCTION__ = "event_dispatch_epoll_handler"
#10 0x00002aaaaaaeca93 in event_dispatch_epoll (event_pool=0x62c168) at event.c:876
        events = 0x66b498
        size = 2
        i = 0
        ret = 2
        __FUNCTION__ = "event_dispatch_epoll"
#11 0x00002aaaaaaecdef in event_dispatch (event_pool=0x62c168) at event.c:984
        ret = -1
        __FUNCTION__ = "event_dispatch"
#12 0x0000000000405b38 in main (argc=1, argv=0x7fffffffe948) at glusterfsd.c:1391
        ctx = 0x62a010
        ret = 0
Comment 1 shishir gowda 2010-09-16 00:34:24 EDT
Works for me

gluster> peer status 
No peers present
gluster> volume create new1 replica 4 192.168.1.84:/export 192.168.1.84:/export1 192.168.1.84:/export2 192.168.1.84:/export3
Creation of volume new1 has been unsuccessful
Host 192.168.1.84 not a friend

If the issue re-occurs, please post the all the peer status.
Comment 2 Lakshmipathi G 2010-09-16 01:58:41 EDT
without probing ,if create volume command executed ,it crashes glusterd.