This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 763371 (GLUSTER-1639)

Summary: gnfs must check for existing nfs servers and report error
Product: [Community] GlusterFS Reporter: Shehjar Tikoo <shehjart>
Component: nfsAssignee: Shehjar Tikoo <shehjart>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 3.1-alphaCC: gluster-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: RTP Mount Type: nfs
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Shehjar Tikoo 2010-09-18 06:18:23 EDT
Many people are running into scenarios where knfs or another glusterfs server is already running and:

a. exports from the new server dont show up in showmount

or

b. the exports show up but mount requests fail because the client sends the mount request to the old nfs servers, failing the requests.


The trick is to perform getport requests to check whether the portmapper already has a registration for nfs and associated protocols.
Comment 1 Amar Tumballi 2011-04-25 05:33:27 EDT
Please update the status of this bug as its been more than 6months since its filed (bug id < 2000)

Please resolve it with proper resolution if its not valid anymore. If its still valid and not critical, move it to 'enhancement' severity.
Comment 2 Shehjar Tikoo 2011-04-25 23:12:14 EDT
Closing. nobody is complaining without this feature.