Bug 763717 (GLUSTER-1985)

Summary: peer detach fails if bricks are not resolved
Product: [Community] GlusterFS Reporter: Pranith Kumar K <pkarampu>
Component: glusterdAssignee: Pranith Kumar K <pkarampu>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 3.1.0CC: gluster-bugs, rahulcs
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Pranith Kumar K 2010-10-20 02:42:00 EDT
peer detach of an invalid peer gives the error bricks exist if the bricks are not resolved. This happens because the peer and the brick have null uuids. This should be handled.
Comment 1 Anand Avati 2010-10-24 21:13:57 EDT
PATCH: http://patches.gluster.com/patch/5534 in master (mgmt/glusterd: resolve the bricks before comparing uuid)