Bug 763781 (GLUSTER-2049)

Summary: files created in the backend are not visible on mount point
Product: [Community] GlusterFS Reporter: Krishna Srinivas <krishna>
Component: nfsAssignee: Shehjar Tikoo <shehjart>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 3.1.0CC: gluster-bugs, shehjart
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: RTP Mount Type: nfs
Documentation: DNR CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Shehjar Tikoo 2010-11-03 00:57:35 EDT
NFS sets gfids only through the lookup call which means that if a file is seen for the first time throught rdirp request, the file handle will be 0, because a prior lookup wasnt sent on it.

This can happen in situations like:

1. vmstor, which manipulates the backend
2. migration of backend from 3.0 branch.

In 1, because the backends are continuously modified by vmstor's posix, we need to always run with nodirplus mount option at nfs client.

For 2, only to migrate the backend this option is needed. Once the ls -lR to  migrate is complete over the nfs mount,a remount with the readdirp request will work just fine.

Kris will confirm.
Comment 1 Krishna Srinivas 2010-11-03 03:42:55 EDT
files created directly on the backend are not visible on the mount point, this is because nfs issues readdirp which returns entries with blank gfids and hence lookups are never sent to these entries to apply uuids to the entries.
Comment 2 Shehjar Tikoo 2010-11-08 22:22:39 EST
Kris, please re-open if this continues to be a problem with the nordirplus mount option. Thanks.
Comment 3 Shehjar Tikoo 2011-02-21 22:26:49 EST
*** Bug 2125 has been marked as a duplicate of this bug. ***