This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 763839 (GLUSTER-2107)

Summary: 3.1.1qa5 untar kernel during replace-brick
Product: [Community] GlusterFS Reporter: Lakshmipathi G <lakshmipathi>
Component: glusterdAssignee: tcp
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 3.1.1CC: gluster-bugs, vijay
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: RTP Mount Type: fuse
Documentation: DP CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Lakshmipathi G 2010-11-13 06:57:46 EST
with 4dht cluster setup ,fuse mounted it client and did untar kernel.

while untar is running - tried replace-brick (replace brick4 with new brick5) it succeeded but on untar on client fails.

fuse log file can be found /share/tickets/2107
Comment 1 tcp 2011-01-21 06:26:46 EST
Did not hit this bug in my setup. Tried it twice with 3.1.2.
I think I did see some "No such file or directory" errors, but tar continued without any further issues. Are you referring to these error messages as failures?

The way I did it was to run untar on the mount point (fuse mount) and then performed -

gluster volume replace-brick testvol <brick_current> <brick_new> start
gluster volume replace-brick testvol <brick_current> <brick_new> commit

Which log file are you referring to as "fuse log file" ? I looked at all the files in /usr/local/var/log/glusterfs and there doesn't seem to be one under that name.
Comment 2 tcp 2011-01-25 01:16:42 EST
Can you please respond to the update?
Comment 3 Lakshmipathi G 2011-01-25 01:43:12 EST
(In reply to comment #1)
> Did not hit this bug in my setup. Tried it twice with 3.1.2.
> I think I did see some "No such file or directory" errors, but tar continued
> without any further issues. 

On client it displayed mesg like "No such file or directory" but untar operation failed with  mesg like "tar failed due to previous errors "

> 
> Which log file are you referring to as "fuse log file" ? I looked at all the
> files in /usr/local/var/log/glusterfs and there doesn't seem to be one under
> that name.

I was referring to glusterfs client log file. (/usr/local/var/log/glusterfs/<mnt-pt>.log)
Comment 4 tcp 2011-01-25 01:48:30 EST
Can you please check it with 3.1.2 and let me know if you still hit the issue ? (As mentioned in the previous update, my experiment did not hit the issue).
Comment 5 tcp 2011-02-10 00:55:34 EST

*** This bug has been marked as a duplicate of bug 1812 ***