Bug 764559 (GLUSTER-2827)

Summary: Setting up a new log directory does not work
Product: [Community] GlusterFS Reporter: Sachidananda Urs <sac>
Component: glusterdAssignee: Venky Shankar <vshankar>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.2.5CC: amarts, gluster-bugs
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 852313 (view as bug list) Environment:
Last Closed: 2012-09-04 05:05:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: DP CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 852313    

Description Amar Tumballi 2011-04-21 07:06:55 EDT
Do the volume stop and start again.. it will get changed.
Comment 1 Sachidananda Urs 2011-04-21 07:48:28 EDT
(In reply to comment #1)
> Do the volume stop and start again.. it will get changed.

Yep this works.
Comment 2 Sachidananda Urs 2011-04-21 09:29:51 EDT
[root@centos5 tmp]# gluster volume log filename test /tmp/
log filename : successful
[root@centos5 tmp]# 

[root@centos5 tmp]# gluster volume log locate test
log file location: /tmp

The location for logs do not get changed.
Comment 3 Amar Tumballi 2012-04-29 06:16:21 EDT
CLI doesn't support 'volume log {filename,locate}' commands in 3.3.0
Comment 4 Amar Tumballi 2012-09-04 05:05:29 EDT
not working on 'log *' commands post 3.3.0