Bug 765014 (GLUSTER-3282)

Summary: Mounting from localhost in fstab fails at boot on ubuntu (upstart)
Product: [Community] GlusterFS Reporter: Louis Zuckerman <glusterbugs>
Component: scriptsAssignee: Vijay Bellur <vbellur>
Status: CLOSED CURRENTRELEASE QA Contact: Sachidananda Urs <sac>
Severity: low Docs Contact:
Priority: medium    
Version: mainlineCC: amarts, gluster-bugs, vijay
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: glusterfs-3.4.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-24 17:25:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
glusterd upstart job (/etc/init/glusterd.conf) none

Description Louis Zuckerman 2011-07-29 17:52:02 UTC
Created attachment 592

Comment 1 Louis Zuckerman 2011-07-29 18:58:40 UTC
I asked about this issue on Fedora/CentOS platforms in IRC and it seems to only affect Ubuntu, and not the other distributions that use upstart.  This is most likely due to the fact that Ubuntu uses the mountall program to handle fstab mounts while other distributions do it some other way.

Comment 2 Louis Zuckerman 2011-07-29 19:24:25 UTC
see also http://review.gluster.com/126

Comment 3 Louis Zuckerman 2011-07-29 20:48:16 UTC
Ubuntu uses upstart instead of init to bootstrap the system.  As a result, glusterfs mounts in fstab are tried before the glusterd service is running.  In the case where the client is also a server and the volume is mounted from localhost, the mount fails at boot time.  An upstart job for glusterd is needed to correct this.

I have attached my upstart job which I have tested on Ubuntu 10.10 Maverick.  The file should be placed in /etc/init/glusterd.conf, and replaces the old initscript in /etc/init.d/glusterd which can be removed.

This affects all versions of glusterfs on the ubuntu platform.  It may also affect other platforms that use upstart like Fedora (9+) and RHEL/CentOS (6+), though I have not tried them.

Comment 4 Anand Avati 2011-08-04 03:10:50 UTC
CHANGE: http://review.gluster.com/126 (Mounting from localhost in fstab fails at boot on ubuntu when glusterd is started by debian initscript.) merged in master by Anand Avati (avati@gluster.com)

Comment 5 Louis Zuckerman 2012-02-07 15:36:45 UTC
I have been working with Ubuntu devs to get upstart jobs for glusterd in the Ubuntu package for glusterfs-server.  In the process they helped me fix up the upstart job configuration.  I'm committing the new upstart jobs now.

Comment 6 Louis Zuckerman 2012-02-07 16:31:31 UTC
http://review.gluster.com/#change,2727

Comment 7 Anand Avati 2012-03-18 07:35:04 UTC
CHANGE: http://review.gluster.com/2727 (Updated the Ubuntu upstart jobs for glusterd in extras/Ubuntu.) merged in master by Anand Avati (avati@redhat.com)

Comment 8 Sachidananda Urs 2012-06-06 06:14:25 UTC
I do not see any of these changes as part 3.3.0, will be testing again in next release.