This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 765171 (GLUSTER-3439)

Summary: gluster volume status functionality
Product: [Community] GlusterFS Reporter: Vijay Bellur <vijay>
Component: glusterdAssignee: Vijay Bellur <vbellur>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: mainlineCC: amarts, csaba, gluster-bugs, rabhat
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: glusterfs-3.3.0qa9 Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Vijay Bellur 2011-08-18 11:07:52 EDT
Right now, brick monitoring has been implemented. Sample output:

Brick status for volume: dist
Brick							Port	Online	PID
---------------------------------------------------------------------------
deepthought:/export1				        24009	Y	32504
---------------------------------------------------------------------------
nebula:/export2				                24009	Y	32508
Comment 1 Vijay Bellur 2011-08-18 14:03:46 EDT
This bug will be used as a placeholder for bringing forth improvements in volume, brick monitoring. All monitoring information would be made available as part of the output for "gluster volume status <volname>".
Comment 2 Anand Avati 2011-08-19 01:29:20 EDT
CHANGE: http://review.gluster.com/259 (Change-Id: Iea835b9e448e736016da2e44e3c9bfff93f2fa78) merged in master by Anand Avati (avati@gluster.com)
Comment 3 Csaba Henk 2011-08-19 05:02:19 EDT
Why do we require exactly one volume argument?

Wouldn't it be each of intuitive + useful + easy to implement to query a list of given volumes, or all the volumes if no argument is given?

# gluster volume info | sed -n 's/^Volume Name:/volume status/p' | gluster --mode=script

is a bit cumbersome.
Comment 4 Anand Avati 2011-08-19 23:19:18 EDT
CHANGE: http://review.gluster.com/268 (Since 86c818a9 (cli: taking my revenge ...) we cannot assert) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 5 Raghavendra Bhat 2011-09-16 03:17:11 EDT
This is working now. gluster volume status <volname> gives the pid and port numbers of the glusterfs server processes. Checked with glusterfs-3.3.0qa9.

gluster volume status okpa
Brick status for volume: okpa
Brick							Port	Online	PID
---------------------------------------------------------------------------
hyperspace:/mnt/sda7/export1				24009	Y	15691
---------------------------------------------------------------------------
hyperspace:/mnt/sda7/export2				24010	Y	15697
---------------------------------------------------------------------------
hyperspace:/mnt/sda7/export3				24011	Y	15702
---------------------------------------------------------------------------
hyperspace:/mnt/sda7/export4				24012	Y	15707



ps aux | grep gluster
root      4901  0.0  2.6 232016 104844 ?       Ssl  14:19   0:00 glusterd
raghu    14213  0.0  0.0  45084  2864 pts/6    S+   11:52   0:00 ssh shell.gluster.com -l raghavendrabhat
root     15691  0.2  2.4 305104 96628 ?        Ssl  15:44   0:00 /usr/local/sbin/glusterfsd -s localhost --volfile-id okpa.hyperspace.mnt-sda7-export1 -p /etc/glusterd/vols/okpa/run/hyperspace-mnt-sda7-export1.pid -S /tmp/8e938410a6af395b5b06b5ab09353819.socket --brick-name /mnt/sda7/export1 -l /usr/local/var/log/glusterfs/bricks/mnt-sda7-export1.log --brick-port 24009 --xlator-option okpa-server.listen-port=24009
root     15697  0.2  2.4 305104 96656 ?        Ssl  15:44   0:00 /usr/local/sbin/glusterfsd -s localhost --volfile-id okpa.hyperspace.mnt-sda7-export2 -p /etc/glusterd/vols/okpa/run/hyperspace-mnt-sda7-export2.pid -S /tmp/e20c98cb7136e0c9ec9094cc309f23c7.socket --brick-name /mnt/sda7/export2 -l /usr/local/var/log/glusterfs/bricks/mnt-sda7-export2.log --brick-port 24010 --xlator-option okpa-server.listen-port=24010
root     15702  0.2  2.4 305104 96848 ?        Ssl  15:44   0:00 /usr/local/sbin/glusterfsd -s localhost --volfile-id okpa.hyperspace.mnt-sda7-export3 -p /etc/glusterd/vols/okpa/run/hyperspace-mnt-sda7-export3.pid -S /tmp/617aa086e0a90a1dbae704359304a9d0.socket --brick-name /mnt/sda7/export3 -l /usr/local/var/log/glusterfs/bricks/mnt-sda7-export3.log --brick-port 24011 --xlator-option okpa-server.listen-port=24011
root     15707  0.2  2.4 305104 96624 ?        Ssl  15:44   0:00 /usr/local/sbin/glusterfsd -s localhost --volfile-id okpa.hyperspace.mnt-sda7-export4 -p /etc/glusterd/vols/okpa/run/hyperspace-mnt-sda7-export4.pid -S /tmp/890df740358bebe0bdcdd3d791620633.socket --brick-name /mnt/sda7/export4 -l /usr/local/var/log/glusterfs/bricks/mnt-sda7-export4.log --brick-port 24012 --xlator-option okpa-server.listen-port=24012