Bug 765470 (GLUSTER-3738)

Summary: Add-brick gives confusing error message when it fails during replace-brick.
Product: [Community] GlusterFS Reporter: Vijaykumar <vijaykumar>
Component: glusterdAssignee: krishnan parthasarathi <kparthas>
Status: CLOSED CURRENTRELEASE QA Contact: Vijaykumar Koppad <vkoppad>
Severity: medium Docs Contact:
Priority: medium    
Version: pre-releaseCC: bbandari, gluster-bugs, nsathyan, rabhat, shmohan
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: glusterfs-3.4.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-24 13:34:47 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: [RHEL6]-3.2.5qa4,3.3.0qa42 Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 817967    

Description Vijaykumar 2011-10-19 03:24:41 EDT
[root@RHEL6 ~]# gluster volume replace-brick doa start
replace-brick started successfully

[root@RHEL6 exp1]# gluster volume info

Volume Name: doa   
Type: Distributed-Stripe
Status: Started
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Options Reconfigured:
features.limit-usage: /:1GB
features.quota: on

[root@RHEL6 exp1]# gluster volume add-brick doa
Volume doa: replace brick is running and the brick you are trying to add is the destination brick for replace brick

Even though the bricks involved in add-brick are neither part of volume nor replace-brick , it gives above error message.
Comment 1 Anand Avati 2011-10-24 06:17:38 EDT
CHANGE: http://review.gluster.com/631 (add-brick, stop-volume, remove-brick are the operations that are explicitly) merged in release-3.2 by Vijay Bellur (vijay@gluster.com)
Comment 2 Vijaykumar 2011-11-01 22:59:36 EDT
[root@RHEL6 ~]# gluster volume create doa stripe 2
Creation of volume doa has been successful. Please start the volume to access data.
[root@RHEL6 ~]# gluster volume start doa                                                                                                                                Starting volume doa has been successful
[root@RHEL6 ~]# gluster volume replace-brick doa start                                        replace-brick started successfully
[root@RHEL6 ~]# gluster volume add-brick doa
Replace brick is in progress on volume doa. Please try after replace-brick operation is committed or aborted.

It gives appropriate error message now.
Comment 3 shylesh 2012-02-04 00:52:24 EST
Reopening the bug

upon executing the above said said steps replace-brick says "Replace-brick failed to start" and does not give appropriate message
Comment 4 krishnan parthasarathi 2012-02-12 10:43:55 EST
@shylesh, "replace-brick failed to start" is not an inappropriate message, though I agree that it doesn't give the reason why it failed.

This bug is tracking an issue with an error message which was supplying the user with an incorrect message regarding the cause of failure of replace-brick. You should open a new bug to track inadequate error messages. This bug should be reopened only to fix an incomplete fix/patch for the original problem.

Let me know your comments, and if you agree with me, please close this bug and open a different one for the problem you see.
Comment 5 shylesh 2012-02-13 01:56:34 EST
@kp, The fix is not yet in for master so reopened, will close once the patch is in for the master.
Comment 6 Anand Avati 2012-02-14 13:22:16 EST
CHANGE: http://review.gluster.com/2740 (glusterd: Fail volume 'modify' operations when rb is ongoing) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 7 krishnan parthasarathi 2012-02-23 08:19:40 EST
*** Bug 763765 has been marked as a duplicate of this bug. ***
Comment 8 shylesh 2012-05-24 01:31:19 EDT
Now proper error messages will be shown.