Bug 766125

Summary: [abrt] imsettings-1.2.6-1.fc16: __GI___libc_free: Process /usr/libexec/imsettings-daemon was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Wim ten Have <whaveten>
Component: imsettingsAssignee: Akira TAGOH <tagoh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: dakshay, felipevsw, i18n-bugs, jlmeram89, jmj.buckley, kb6tal, mike.cloaked, peljasz, rpiddapa, sarrab1976, sheepdestroyer, tagoh, victor.munteanu, vlademir.segan
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:b5282fb123d7b42863f86e6388361f8c183b551a
Fixed In Version: imsettings-1.2.8-1.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-17 18:50:09 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: dso_list
none
File: maps
none
File: backtrace
none
File: backtrace
none
imsettings log for mike cloaked
none
File: backtrace
none
File: backtrace
none
File: backtrace
none
File: backtrace none

Description Wim ten Have 2011-12-10 07:06:23 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/libexec/imsettings-daemon
crash_function: __GI___libc_free
executable:     /usr/libexec/imsettings-daemon
kernel:         3.1.4-1.fc16.x86_64
pid:            5364
pwd:            /
reason:         Process /usr/libexec/imsettings-daemon was killed by signal 11 (SIGSEGV)
time:           Sat 10 Dec 2011 12:40:00 PM CET
uid:            1500
username:       wtenhave
var_log_messages: Dec 10 12:40:00 Wim-fc abrt[5644]: Saved core dump of pid 5364 (/usr/libexec/imsettings-daemon) to /var/spool/abrt/ccpp-2011-12-10-12:40:00-5364 (18243584 bytes)

backtrace:      Text file, 15198 bytes
dso_list:       Text file, 3153 bytes
maps:           Text file, 15547 bytes

build_ids:
:80d1527bdbaa66a7f4467a3432a25332fb76758a
:3ed9e61c2b7e707ce244816335776afa2ad0307d
:98fa95d21e16075ada6df19748c6c133ee9165d0
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:87461d97d0ba0bd94e4d74ff0879190b67b326c5
:5e8c36ca13a4af14fa6b1b45a0dbfb43ed6aed6e
:ab59942678bcdecb23756804dcd0aac63ccc1669
:30af62b93e2ab7dbaf39c52e346cd52101b4b590
:9d1209fc79304f03cc839de1c0036c61b48dfff8
:638db099ff5fb986d1a092629d1bb1dca5be4904
:e5429e0905bedecc534b057783916ba43e06a66e
:44ece411beb2ef1acdb5eb2161666de41cc2f31d
:48d3cff26c916dff6cbcb5e67d5cf6d391f6ccca
:6276a60cb92dc220215733e10e4b415a50f6c862
:0f0c9eed63ed279ceb0aef109eff8bcbb351e4bb
:4953d1f613914126bccceb3cb96386647ffba9df
:e2e67b3ae2579e1667b73ad385f61552931024e9
:ccadad4ec7dab3bb6abc23f9d4cdf53ff01cb235
:2d97dbef2fbf464ea323d110662fbb391445c600
:2fd6dbe0359154b7cf4e0af02e3aa0f9ec819f11
:b0eabf9093defbfdd0857ea3ed1a4563b743434e
:aa733447f84020c94a66814e501a36e248cbb43d
:b0a2d0b4c09d819887ec7d711c8cf3977a074c4f
:362576adc51e9ae9230a4bc77d3486ba351450b1
:c3cc06ceb6e1a99743164a9db770a23d5a68dd47
:be507c791e34415e8f42f0e6030c889b2895cf9a
:e5d7ac2dfe435e205e491f7ce827563859fca4f4
:c4924db04d383a9bc47e4b574ab6aab112a3169e
:3e2404bd469800afd61eda83d0292a2165ef0db0
:545fac2346ca24589041213956b7f22f7e91c139
:650b733aecfb9c46bdfc023661f19244a278df04
:022f1a6511ab7f46cc5b6f0df5852b50dfd46c85
:88d586ed67ebe5227b761b4ab2e02433f29c840f
:0949b493f01e0553822be3bd14def9dbe79b804f

environ:
:SHELL=/bin/csh
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-H7OzCZLHXT,guid=22a7b02140afe8458102e4a4000021c4
:XDG_SESSION_COOKIE=7a8315981fce3d0f0fc5c2520000000a-1323517191.65839-2055168016
:XDG_RUNTIME_DIR=/run/user/wtenhave
:DISPLAY=:0
:DESKTOP_SESSION=kde-plasma
:WINDOWPATH=2
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=kde-plasma
:XDG_VTNR=2
:USERNAME=wtenhave
:XDG_SESSION_ID=8
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-H7OzCZLHXT,guid=22a7b02140afe8458102e4a4000021c4
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-wtenhave-OBRuL7/database
:USER=wtenhave
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=5280
:SHLVL=1
:PWD=/home/wtenhave
:GNOME_KEYRING_CONTROL=/tmp/keyring-ct51mk
:LANG=en_US.UTF-8
:_=/usr/bin/dbus-launch
:LOGNAME=wtenhave
:HOME=/home/wtenhave
Comment 1 Wim ten Have 2011-12-10 07:06:25 EST
Created attachment 544860 [details]
File: dso_list
Comment 2 Wim ten Have 2011-12-10 07:06:28 EST
Created attachment 544861 [details]
File: maps
Comment 3 Wim ten Have 2011-12-10 07:06:30 EST
Created attachment 544862 [details]
File: backtrace
Comment 4 Mike C 2012-01-06 11:47:28 EST
I logged in!

rating: 4
Package: imsettings-1.2.6-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)
Comment 5 Mike C 2012-01-06 11:54:10 EST
I don't know if this is a coincidence but after updating to:
xfconf-4.8.1-1.fc16.x86_64
and
xfwm4-4.8.3-1.fc16.x86_64

This has stopped occurring...
Comment 6 Mike C 2012-01-06 16:37:58 EST
This just occurred again so will submit new report via abrt....
Comment 7 Mike C 2012-01-06 16:39:35 EST
#772342
Comment 8 Juan León 2012-01-15 09:27:20 EST
turn on the computer

rating: 4
Package: imsettings-1.2.6-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)
Comment 9 Mike C 2012-01-15 09:45:11 EST
I am not sure I understand what comment #8 implies?  Can you offer a little more explanation.  By the way after updating the orc package I have not seen this occurring on my machine so it is possible that the orc package was responsible for this bug as well as a few others related to gstreamer.  However I have now not had any recurrence for a week or so. I know the original bug was related to kde but it would be useful to know if the original reporter has seen the problem recently or if it has not recurred.
Comment 10 Jim Walden 2012-01-15 19:40:00 EST
I had just updated the system and rebooted. When I signed back in there was an icon with a problem message.

backtrace_rating: 4
Package: imsettings-1.2.6-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 11 Jim Walden 2012-01-15 19:40:03 EST
Created attachment 555407 [details]
File: backtrace
Comment 12 Akira TAGOH 2012-01-15 21:49:45 EST
Does this issue happen every startup time for you? I want to reproduce this if possible. can you please provide more detailed information such as how many ibus-engines you installed, your locale, current IM configuration etc?

To collect the ibus-engine packages, this might helps:
$ for i in /usr/share/ibus/component/*; do rpm -qf $i; done|sort|uniq

For locale information:
$ locale

For IM configuration, please attach your $HOME/.imsettings.log
Comment 13 Mike C 2012-01-16 10:04:00 EST
Although I have not had a repeat of this issue after updates about a week ago.

However for completeness my info that you requested (that may be useful as a comparison with that of Jim) is:

[mike@samsung1 ~]$ for i in /usr/share/ibus/component/*; do rpm -qf $i; done|sort|uniq
ibus-1.4.0-17.fc16.i686
ibus-m17n-1.3.3-7.fc16.i686
ibus-rawcode-1.3.1.20100707-5.fc16.i686
[mike@samsung1 ~]$ locale
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
[mike@samsung1 ~]$ 

I will also attach my imsettings.log shortly - as I said I have not had a repeat of this since my comments to this report earlier.
Comment 14 Mike C 2012-01-16 10:05:03 EST
Created attachment 555526 [details]
imsettings log for mike cloaked
Comment 15 Felipe van Schaik Willig 2012-01-16 15:42:58 EST
This error appeared when I booted up first time on the day.

backtrace_rating: 4
Package: imsettings-1.2.6-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 16 Felipe van Schaik Willig 2012-01-16 15:43:02 EST
Created attachment 555597 [details]
File: backtrace
Comment 17 mamii 2012-01-28 11:32:30 EST
enter on gnome shell and look screen

backtrace_rating: 4
Package: imsettings-1.2.6-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 18 mamii 2012-01-28 11:32:43 EST
Created attachment 558067 [details]
File: backtrace
Comment 19 lejeczek 2012-02-02 03:12:45 EST
in System setting I changed Fallback mode ON, logged out and logged in, changed back to OFF, logged out and in, then this crash

backtrace_rating: 3
Package: imsettings-1.2.6-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 20 lejeczek 2012-02-02 03:12:50 EST
Created attachment 559008 [details]
File: backtrace
Comment 21 Fedora Update System 2012-02-10 02:38:44 EST
imsettings-1.2.8-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/imsettings-1.2.8-1.fc16
Comment 22 Fedora Update System 2012-02-10 17:01:25 EST
Package imsettings-1.2.8-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing imsettings-1.2.8-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1545/imsettings-1.2.8-1.fc16
then log in and leave karma (feedback).
Comment 23 Joe Buckley 2012-02-12 07:41:28 EST
Booted up.

backtrace_rating: 4
Package: imsettings-1.2.7.1-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 24 Joe Buckley 2012-02-12 07:41:35 EST
Created attachment 561210 [details]
File: backtrace
Comment 25 Fedora Update System 2012-02-17 18:50:09 EST
imsettings-1.2.8-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.