Bug 766543

Summary: error compiling mesa 7.11.2 on ARM hardfp/softfp
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: jakub
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-02 11:47:08 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 245418    
Attachments:
Description Flags
.out file from build none

Description Peter Robinson 2011-12-12 05:11:47 EST
In a follow up to bug #713609 but for mesa-7.11.2-1 on F-15 arm I'm getting the following build errors when building on ARM.

gcc -c -I. -I../../../../src/gallium/include -I../../../../src/gallium/auxiliary -I../../../../src/gallium/drivers -I../../../../src/gallium/drivers/svga/include -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -Wall -Wmissing-prototypes -std=c99 -ffast-math -fno-strict-aliasing -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -fPIC -D_GNU_SOURCE -DPTHREADS -DHAVE_POSIX_MEMALIGN -DMESA_SELINUX -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS -DHAVE_LIBUDEV -DHAVE_XCB_DRI2 -DXCB_DRI2_CONNECT_DEVICE_NAME_BROKEN -DGALLIUM_LLVMPIPE -D__STDC_CONSTANT_MACROS -DHAVE_LLVM=0x0208 -fvisibility=hidden -std=gnu99 -fvisibility=hidden -DHAVE_STDINT_H -DHAVE_SYS_TYPES_H -I/usr/include  -DNDEBUG -D_GNU_SOURCE -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS svga_tgsi_decl_sm30.c -o svga_tgsi_decl_sm30.o
svga_tgsi_decl_sm30.c: In function 'ps30_output':
svga_tgsi_decl_sm30.c:193:26: warning: variable 'reg' set but not used [-Wunused-but-set-variable]
svga_tgsi_decl_sm30.c: In function 'svga_translate_decl_sm30':
svga_tgsi_decl_sm30.c:351:13: warning: variable 'semantic_idx' set but not used [-Wunused-but-set-variable]
svga_tgsi_decl_sm30.c:350:13: warning: variable 'semantic' set but not used [-Wunused-but-set-variable]
gcc -c -I. -I../../../../src/gallium/include -I../../../../src/gallium/auxiliary -I../../../../src/gallium/drivers -I../../../../src/gallium/drivers/svga/include -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -Wall -Wmissing-prototypes -std=c99 -ffast-math -fno-strict-aliasing -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -fPIC -D_GNU_SOURCE -DPTHREADS -DHAVE_POSIX_MEMALIGN -DMESA_SELINUX -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS -DHAVE_LIBUDEV -DHAVE_XCB_DRI2 -DXCB_DRI2_CONNECT_DEVICE_NAME_BROKEN -DGALLIUM_LLVMPIPE -D__STDC_CONSTANT_MACROS -DHAVE_LLVM=0x0208 -fvisibility=hidden -std=gnu99 -fvisibility=hidden -DHAVE_STDINT_H -DHAVE_SYS_TYPES_H -I/usr/include  -DNDEBUG -D_GNU_SOURCE -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS svga_tgsi_insn.c -o svga_tgsi_insn.o
svga_tgsi_insn.c: In function 'svga_shader_emit_instructions':
svga_tgsi_insn.c:3071:1: internal compiler error: in push_minipool_fix, at config/arm/arm.c:12094
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccqOGJZN.out file, please attach this to your bugreport.
gmake[4]: *** [svga_tgsi_insn.o] Error 1
gmake[4]: Leaving directory `/builddir/build/BUILD/Mesa-7.11.2/src/gallium/drivers/svga'
gmake[3]: Leaving directory `/builddir/build/BUILD/Mesa-7.11.2/src/gallium/drivers'
gmake[3]: *** [default] Error 1
gmake[2]: Leaving directory `/builddir/build/BUILD/Mesa-7.11.2/src/gallium'
gmake[2]: *** [default] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/Mesa-7.11.2/src'
make[1]: *** [subdirs] Error 1
make: *** [default] Error 1

Full output in the log here:

http://arm.koji.fedoraproject.org/koji/getfile?taskID=233410&name=build.log

Full task here:
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=233408
Comment 1 Adam Jackson 2011-12-20 15:11:34 EST
ICE in gcc -> gcc bug
Comment 2 Jakub Jelinek 2011-12-20 16:48:32 EST
Preprocessed source stored into /tmp/ccqOGJZN.out file, please attach this to
your bugreport.
Comment 3 Dennis Gilmore 2011-12-26 16:42:45 EST
Created attachment 549626 [details]
.out file from build
Comment 4 Peter Robinson 2011-12-27 08:59:45 EST
Looks like its this gcc bug as reported in the Linaro bug tracker

https://bugs.launchpad.net/gcc-linaro/+bug/788841
Comment 5 Peter Robinson 2012-03-02 11:47:08 EST
mesa compiles fine on f-17 ARM