Bug 767128

Summary: Empathy doesn't remember certificate trust setting
Product: [Fedora] Fedora Reporter: info <info>
Component: empathyAssignee: Brian Pepple <bdpepple>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 16CC: bdpepple, debarshir
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-10 16:38:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description info@kobaltwit.be 2011-12-13 10:34:56 UTC
Description of problem:
I have configured a jabber account in empathy. Each time empathy starts, it warns me that the jabber certificate is not trusted:

"This connection is untrusted. Would you like to continue anyway?
The identity provided by the chat server cannot be verified.
The certificate is self-signed."

I tick "Remember this choice for future connections."

And click continue after which the connection comes up properly. However, if I quit empathy and restart it, it will ask me the same question again. So it doesn't seem to save my preference of not asking me that same question again.

Version-Release number of selected component (if applicable):
empathy-3.2.2-1.fc16.i686

How reproducible:
Always

Steps to Reproduce:
1. Start empathy
2. Setup a jabber account (this service has a certificate that empathy won't trust)
3. Restart empathy
=> Note that empathy asks you whether or not to trust the certificate.
4. Tick "Remember this choice for future connections" and then click continue
5. Now quit empathy and restart it.

Actual results:
You are asked to trust the certificate again even though you had explicitly told empathy to remember your preference.

Expected results:
Empathy should honour your preference and not ask again if you want to trust the certificate.

Additional info:
I am using empathy within kde, but the same happens when I start a gnome session.

Comment 1 Debarshi Ray 2012-03-06 18:07:37 UTC
Works for me in GNOME with latest updates. Is this still bothering you?

Comment 2 info@kobaltwit.be 2012-04-12 12:12:00 UTC
It is, but I'm on KDE.

In the meantime I found bug 641526 and I suspect my bug is a duplicate of that one. At least the certificate that is being complained about in my case is self-signed as well.

Comment 3 Brian Pepple 2012-05-10 16:38:11 UTC

*** This bug has been marked as a duplicate of bug 641526 ***