Bug 76715

Summary: Nautilus does not pick up new fonts until restarted
Product: [Retired] Red Hat Linux Reporter: Michel Alexandre Salim <michel.salim>
Component: pangoAssignee: Owen Taylor <otaylor>
Status: CLOSED WONTFIX QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: srevivo
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-10-25 11:13:11 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Michel Alexandre Salim 2002-10-25 06:22:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021023

Description of problem:
After adding new fonts to ~/.fonts, I find that Nautilus does not pick up the
new font as selected in Preferences->Fonts until I 'killall nautilus'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add a new font to ~/.fonts
2. Change the desktop font in Preferences->Font to the new font

	

Actual Results:  Nautilus reverts to standard font

Expected Results:  Nautilus uses the new font to render the desktop

Additional info:

Nautilus only checks the list of fonts on startup? Perhaps it can be patched so
if it's told to use a font it does not know about, it rebuilds its font cache?
Comment 1 Owen Taylor 2002-10-25 12:06:42 EDT
Really hard to fix; hopefully we'll get to it someday, but I don't
see leaving a bug open for it... it's one of those general improvements
that we won't forget about.