Bug 767404

Summary: Handling of Unicode characters is completely broken (prints Latin1 characters instead of locale ones)
Product: [Fedora] Fedora EPEL Reporter: Matěj Cepl <mcepl>
Component: ipythonAssignee: David Cantrell <dcantrell>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: el6CC: dcantrell, mcepl, mrunge, tomspur
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ipython-0.13.2-4.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-27 15:29:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
suggested patch on .spec file none

Description Matěj Cepl 2011-12-13 23:52:02 UTC
Created attachment 546462 [details]
suggested patch on .spec file

Description of problem:
Just with attached patch against the master branch, I was able to build ipython 0.11 from the mater branch in EL-6 in koji http://koji.fedoraproject.org/koji/taskinfo?taskID=3583548

Comment 1 Thomas Spura 2011-12-14 00:02:55 UTC
(In reply to comment #0)
> Created attachment 546462 [details]
> suggested patch on .spec file
> 
> Description of problem:
> Just with attached patch against the master branch, I was able to build ipython
> 0.11 from the mater branch in EL-6 in koji
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3583548

Building doesn't matter much I guess...

This release breaks basically everything from 0.10 (new config system - all previous configurations can me moved to /dev/null..., different modules, breaks e.g. python-polybori and spyder)

That's why I didn't push this to a released Fedora version because it's against the Updates Criteria, we have there, and I highly guess EPEL has more strict ones...

Where you aware of these changes?

Are there good reasons to update anyway? ;)

Comment 2 Matěj Cepl 2011-12-14 14:36:28 UTC
(In reply to comment #1)
> Where you aware of these changes?
> 
> Are there good reasons to update anyway? ;)

No, I have no clue about ipython at all and even less about its packaging. I was just irked by completely broken dealing with Unicode strings in ipython, which I found was fixed in 0.11. Yes, I should spend time browsing through commits before 0.11 to find how it has been fixed, but just rebuild fixed this for me.

So, I agree, rebasing is probably a bad idea (especially for EPEL). OTOH, fixing Unicode dealing would be awesome, but I have no clue how to do it. See this part of the session with Django shell (which is ipython under the cover):

In [1]: from coelodonta.models import *

In [4]: cat = Category(name=u"řeřicha")

In [5]: cat
Out[5]: <Category: category: ÅeÅicha>

Comment 3 Matěj Cepl 2011-12-14 14:39:20 UTC
BTW, the same story with --plain shell (i.e., using /usr/bin/python instead of ipython for interactive shell)

mitmanek:openshift (next) $ python manage.py shell --plain
Python 2.6.6 (r266:84292, Sep 12 2011, 14:03:14) 
[GCC 4.4.5 20110214 (Red Hat 4.4.5-6)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
(InteractiveConsole)
>>> from coelodonta.models import *
>>> cat = Category(name=u"řeřicha")
>>> cat
<Category: category: řeřicha>
>>>

Comment 4 David Cantrell 2014-06-13 12:57:36 UTC
Given that 0.11 is a complete overhaul of ipython, I don't backporting patches is a valuable use of time.  As indicated in previous comments, the goal is to have working Unicode support.

Since ipython is primarily interactive, I think the risk of rebasing is ok.  I'll prepare a test candidate and let people try it out.  I'm not going to rebase to the latest stable release, but rather just the latest 0.x release to keep it somewhat close to the 0.10 series.

Please try out the test candidate to see if it fixes up Unicode support for you.

Comment 5 Fedora Update System 2014-06-13 15:44:52 UTC
ipython-0.13.2-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ipython-0.13.2-4.el6

Comment 6 Fedora Update System 2014-06-14 20:00:14 UTC
Package ipython-0.13.2-4.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ipython-0.13.2-4.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1645/ipython-0.13.2-4.el6
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-06-27 15:29:38 UTC
ipython-0.13.2-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.