Bug 768240

Summary: dependency problem when libreoffice replaced with OO.org rpms
Product: [Fedora] Fedora Reporter: gene smith <gds>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 16CC: caolanm, dtardon, erack, ltinkl, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-16 01:56:20 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description gene smith 2011-12-16 01:09:18 EST
Description of problem:
With LOffice, some graphics in writer documents don't show up completely (lines are missing, etc.). Never had this problem in <=f14 with OO so removed LO and installed OO from setup installer. This fixed the graphics problem. However, shortly a yum (or apper) update appeared for libreoffice-ure which was no longer installed (now openoffice.org-ure installed). When update applied, errors like this are seen:
Error: Package: openoffice.org3-dict-fr-3.3.0-9567.x86_64 (installed)
           Requires: openoffice.org-ure
           Removing: openoffice.org-ure-1.7.0-9567.x86_64 (installed)
               openoffice.org-ure = 1.7.0-9567
           Obsoleted By: 1:libreoffice-ure-3.4.4.2-3.fc16.x86_64 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

A workaround solution is to be exclude=libreoffice* in yum.conf. This seems to point to a packaging error of some sort.

Version-Release number of selected component (if applicable):
f16, LO version=latest for f16, OO version installed from OO site: 3.3

How reproducible:
Always

Steps to Reproduce:
1. Remove LOffice using yum remove libreoffice*
2. Install OO.org setup rpms from their site (used their setup program and installed as root to /opt)
3. Wait a while or immediately do a yum update
4. See a need to update (now non-existent) libreoffice-ure
5. Update fails
  
Actual results:
Update fails. Must add exclude=libreoffice* to yum.conf to inhibit this from flagging a need to update which will always fails.

Expected results:
Should just be able to remove LO and install OO with no linkage or phantom errors.

Additional info:
The original graphics problem with LOffice is not fedora specific since I saw it with Ubuntu also and installed OO.org as a replacement to fix the problem. There was no problems doing this with Ubuntu.
Comment 1 David Tardon 2011-12-16 01:56:20 EST
(In reply to comment #0)
> Description of problem:
> With LOffice, some graphics in writer documents don't show up completely (lines
> are missing, etc.). Never had this problem in <=f14 with OO so removed LO and
> installed OO from setup installer. This fixed the graphics problem. However,
> shortly a yum (or apper) update appeared for libreoffice-ure which was no
> longer installed (now openoffice.org-ure installed). When update applied,
> errors like this are seen:
> Error: Package: openoffice.org3-dict-fr-3.3.0-9567.x86_64 (installed)
>            Requires: openoffice.org-ure
>            Removing: openoffice.org-ure-1.7.0-9567.x86_64 (installed)
>                openoffice.org-ure = 1.7.0-9567
>            Obsoleted By: 1:libreoffice-ure-3.4.4.2-3.fc16.x86_64 (updates)
>                Not found
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest

Which is how it should be: our libreoffice-ure package obsoletes openoffice.org-ure to provide a smooth updgrade path from F-14's openoffice.org to F-15/16's libreoffice (which is required by Fedora). Unfortunately, one of the OO.o's upstream rpms has the same name (i.e., openoffice.org-ure), which causes the problem.

> 
> A workaround solution is to be exclude=libreoffice* in yum.conf. This seems to
> point to a packaging error of some sort.

This is not a workaround but the solution. Fedora only ascertains package compatibility and correct upgrade paths inside the distribution. It is just not possible to support random third-party stuff in addition.

> 
> Actual results:
> Update fails. Must add exclude=libreoffice* to yum.conf to inhibit this from
> flagging a need to update which will always fails.

Again, this is the right thing to do.

> 
> Expected results:
> Should just be able to remove LO and install OO with no linkage or phantom
> errors.

No. When you start mixing distribution and third-party packages, you are on your own.

> 
> Additional info:
> The original graphics problem with LOffice is not fedora specific since I saw
> it with Ubuntu also and installed OO.org as a replacement to fix the problem.

And where is the bug report for it?
Comment 2 gene smith 2011-12-16 19:52:04 EST
(In reply to comment #1)

> And where is the bug report for it?

This show exactly what I see. When .doc opened in LO that contains graphical elements with lines and text. You see only the text and no lines with LO:

https://bugs.freedesktop.org/show_bug.cgi?id=42112

In OO the graphical elements appear correctly. Since I really need to open these documents I replace LO with OO. Hopefully, this will be fixed but I don't see a lot of activity on this bug at LO bugzilla.