Bug 768549

Summary: firefox randomly freezes / crashes
Product: [Fedora] Fedora Reporter: Eugene Kanter <ekanter>
Component: glibcAssignee: Jeff Law <law>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gecko-bugs-nobody, jakub, law, schwab
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-20 14:25:34 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Eugene Kanter 2011-12-16 18:37:26 EST
Description of problem:

firefox randomly freezes / crashes

Version-Release number of selected component (if applicable):

firefox-8.0-3.fc16.x86_64
glibc-2.14.90-21.x86_64


How reproducible:

frequently

Steps to Reproduce:
start firefox, attach gdb
gdb --pid=nnnnn /usr/lib64/firefox/firefox

start using firefox, nothing in particular besides heavy usage with many tabs open. no flash plugin enabled, nspluginwrapper is not installed.
  
Actual results:

after some time

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7fa5462f8700 (LWP 21700)]
0x0000003047c36285 in raise () from /lib64/libc.so.6
(gdb) where
#0  0x0000003047c36285 in raise () from /lib64/libc.so.6
#1  0x0000003047c37b9b in abort () from /lib64/libc.so.6
#2  0x0000003047c2ee9e in __assert_fail_base () from /lib64/libc.so.6
#3  0x0000003047c2ef42 in __assert_fail () from /lib64/libc.so.6
#4  0x000000304ac094dc in __libc_res_nquery () from /lib64/libresolv.so.2
#5  0x000000304ac09695 in __libc_res_nquerydomain () from /lib64/libresolv.so.2
#6  0x000000304ac09b69 in __libc_res_nsearch () from /lib64/libresolv.so.2
#7  0x00007fa58a3f23ec in _nss_dns_gethostbyname4_r ()
   from /lib64/libnss_dns.so.2
#8  0x0000003047cd8b99 in gaih_inet () from /lib64/libc.so.6
#9  0x0000003047cdc1ce in getaddrinfo () from /lib64/libc.so.6
#10 0x0000003054c1c88f in PR_GetAddrInfoByName () from /lib64/libnspr4.so
#11 0x00007fa59384b9e5 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#12 0x0000003054c28713 in ?? () from /lib64/libnspr4.so
#13 0x0000003048007d90 in start_thread () from /lib64/libpthread.so.0
#14 0x0000003047cef3dd in clone () from /lib64/libc.so.6


This started after F15 to F16 upgrade.
Comment 1 Eugene Kanter 2011-12-19 17:25:57 EST
(gdb) where
#0  0x0000003047c36285 in __GI_raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x0000003047c37b9b in __GI_abort () at abort.c:91
#2  0x0000003047c2ee9e in __assert_fail_base (fmt=<optimized out>, 
    assertion=0x304ac149f8 "hp != hp2", file=0x304ac149e2 "res_query.c", 
    line=<optimized out>, function=<optimized out>) at assert.c:94
#3  0x0000003047c2ef42 in __GI___assert_fail (
    assertion=0x304ac149f8 "hp != hp2", file=0x304ac149e2 "res_query.c", 
    line=258, function=0x304ac14a50 "__libc_res_nquery") at assert.c:103
#4  0x000000304ac094dc in __libc_res_nquery (statp=0x7fffad5ffdb8, 
    name=0x7fffbfff3cc8 "ocsp.entrust.net", class=1, type=62321, 
    answer=<optimized out>, anslen=2048, answerp=0x7fffad5fe520, 
    answerp2=0x7fffad5fe530, nanswerp2=0x7fffad5fe58c, resplen2=0x7fffad5fe570)
    at res_query.c:258
#5  0x000000304ac09695 in __libc_res_nquerydomain (statp=0x7fffad5ffdb8, 
    name=0x7fffbfff3cc8 "ocsp.entrust.net", domain=<optimized out>, class=1, 
    type=62321, answer=0x7fffad5fdce0 "\351\u04c1\200", anslen=2048, 
    answerp=0x7fffad5fe520, answerp2=0x7fffad5fe530, nanswerp2=0x7fffad5fe58c, 
    resplen2=0x7fffad5fe570) at res_query.c:578
#6  0x000000304ac09b69 in __libc_res_nsearch (statp=0x7fffad5ffdb8, 
    name=0x7fffbfff3cc8 "ocsp.entrust.net", class=1, type=62321, 
    answer=0x7fffad5fdce0 "\351\u04c1\200", anslen=2048,answerp=0x7fffad5fe520, 
    answerp2=0x7fffad5fe530, nanswerp2=0x7fffad5fe58c, resplen2=0x7fffad5fe570)
    at res_query.c:378
#7  0x00007fffecef23ec in _nss_dns_gethostbyname4_r (
    name=0x7fffbfff3cc8 "ocsp.entrust.net", pat=0x7fffad5feb40, 
    buffer=0x7fffad5fe5f0 "\300\250\002\001", buflen=1024, 
    errnop=0x7fffad5feb70, herrnop=0x7fffad5feb80, ttlp=0x0)
    at nss_dns/dns-host.c:314
#8  0x0000003047cd8b99 in gaih_inet (name=0x7fffbfff3cc8 "ocsp.entrust.net", 
    service=<optimized out>, req=0x7fffad5fedd0, pai=<optimized out>, 
    naddrs=0x7fffad5fed70) at ../sysdeps/posix/getaddrinfo.c:842
#9  0x0000003047cdc1ce in __GI_getaddrinfo (
    name=0x7fffbfff3cc8 "ocsp.entrust.net", service=<optimized out>, 
    hints=0x7fffad5fedd0, pai=0x7fffad5fee08)
    at ../sysdeps/posix/getaddrinfo.c:2356
#10 0x0000003054c1c88f in PR_GetAddrInfoByName () from /lib64/libnspr4.so
#11 0x00007ffff634b9e5 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#12 0x0000003054c28713 in ?? () from /lib64/libnspr4.so
#13 0x0000003048007d90 in start_thread (arg=0x7fffad5ff700)
    at pthread_create.c:309
#14 0x0000003047cef3dd in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
(gdb)
Comment 2 Jeff Law 2011-12-20 14:25:34 EST

*** This bug has been marked as a duplicate of bug 730856 ***