Bug 769693

Summary: Drop augeas overrides from ovirt-node
Product: Red Hat Enterprise Linux 6 Reporter: Mike Burns <mburns>
Component: ovirt-nodeAssignee: Mike Burns <mburns>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.3CC: acathrow, bsarathy, dougsland, gouyang, jboggs, leiwang, mburns, ovirt-bugs, ovirt-maint, sgordon, ycui
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: ovirt-node-2.2.3-1.el6 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: 769052 Environment:
Last Closed: 2012-07-19 10:17:07 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 769052    
Bug Blocks: 752464    

Description Mike Burns 2011-12-21 13:51:34 EST
+++ This bug was initially created as a clone of Bug #769052 +++

Description of problem:

ovirt-node-2.2.0-1.fc16.noarch

I have been trying to install oVirt Node using USB/CDROM approach but unfortunately it's not working anymore in my system. During the boot it goes directly to shell instead of go to ovirt-admin-shell.

Additional info:

- /tmp is Read-only file system
- No ovirt.log
- messages is empty

--- Additional comment from dougsland@redhat.com on 2011-12-20 09:29:46 EST ---

Just to share, I have build a ovirt-node 2.1 version and I see the same behavior.

--- Additional comment from mburns@redhat.com on 2011-12-20 09:48:12 EST ---

(In reply to comment #1)
> Just to share, I have build a ovirt-node 2.1 version and I see the same
> behavior.

This means that the problem is not ovirt-node.  It's some other update that has gone into Fedora.  Likely suspects from recent updates are kernel and dracut.

--- Additional comment from mburns@redhat.com on 2011-12-21 13:50:41 EST ---

This is due to updates in augeas.  Due to other issues, we were shipping some override files for augeas that were breaking some augeas lenses (though not ones we were using.
Comment 1 Mike Burns 2011-12-21 13:53:04 EST
We should remove all augeas overrides and use only core augeas scripts.  Other workaround scripts, if needed, should be accompanied by augeas bugs and bugs to revert workarounds when no longer needed.
Comment 3 Guohua Ouyang 2012-02-21 02:53:33 EST
Verified on 6.3-20120215 build, install from usb came to installation tui correctly, after the install finish and reboot, it come to login prompt and can login correctly.

set bug status to be verified.
Comment 5 Mike Burns 2012-03-27 17:01:35 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
mburns reviewed, no tech note needed
Comment 6 Stephen Gordon 2012-06-15 09:58:12 EDT
Deleted Technical Notes Contents.

Old Contents:
mburns reviewed, no tech note needed
Comment 8 errata-xmlrpc 2012-07-19 10:17:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html