Bug 770274

Summary: eth0 loses connection
Product: [Fedora] Fedora Reporter: dev002
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-28 09:54:41 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description dev002 2011-12-25 08:01:56 EST
Description of problem:
eth0 loses connection with link up

Version-Release number of selected component (if applicable):
3.*

How reproducible:
plug rj45, ..., wait, undefined moment eth0 connectivity disappears

Steps to Reproduce:
1.plug rj45
2.use connection
3.no packets on interface, but link up
  
Actual results:
no working LAN card

Expected results:
working LAN card

Additional info:

[ 1392.016075] ------------[ cut here ]------------
[ 1392.016105] WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0x1d6/0x1e0()
[ 1392.016112] Hardware name:
[ 1392.016118] NETDEV WATCHDOG: eth0 (r8169): transmit queue 0 timed out
[ 1392.016124] Modules linked in: bluetooth rfkill fuse act_police cls_flow cls_fw cls_u32 sch_tbf sch_prio
sch_hfsc sch_htb sch_ingress sch_sfq xt_realm xt_addrtype iptable_raw xt_connlimit xt_comment xt_recent ipt_ULOG ipt_REDIRECT ipt_NETMAP ip
t_MASQUERADE ipt_ECN ipt_ecn ipt_CLUSTERIP ipt_ah nf_nat_tftp nf_nat_snmp_basic nf_conntrack_snmp nf_nat_sip nf_nat_pptp nf_nat_proto_gre i
p6_queue nf_nat_irc nf_nat_h323 xt_set ip_set nf_nat_ftp nf_nat_amanda nf_conntrack_tftp nf_conntrack_sane nf_conntrack_sip nf_conntrack_pr
oto_udplite nf_conntrack_proto_sctp nf_conntrack_pptp nf_conntrack_proto_gre nf_conntrack_netlink nf_conntrack_netbios_ns nf_conntrack_broa
dcast nf_conntrack_irc ts_kmp nf_conntrack_h323 nf_conntrack_amanda nf_conntrack_ftp xt_time xt_TCPMSS xt_TPROXY nf_tproxy_core xt_tcpmss x
t_sctp xt_policy xt_pkttype xt_physdev xt_owner xt_NFLOG nfnetlink_log xt_NFQUEUE xt_multiport xt_mark xt_mac xt_limit xt_length xt_iprange
 xt_helper xt_hashlimit xt_DSCP xt_dscp xt_dccp xt_con
nmark xt_AUDIT xt_CLASSIFY ipt_LOG ip6t_LOG ip6t_REJECT iptable_nat nf_nat xt_state nf_conntrack_ipv4 nf_con
ntrack_ipv6 nf_defrag_ipv4 nf_defrag_ipv6 xt_conntrack nf_conntrack ip6table_raw iptable_mangle ip6table_mangle nfnetlink padlock_aes via d
rm via_rng ip6table_filter ip6_tables it87 hwmon_vid snd_via82xx gameport snd_ac97_codec ac97_bus snd_seq snd_pcm snd_timer snd_page_alloc
snd_mpu401_uart snd_rawmidi snd_seq_device snd i2c_viapro i2c_core via_rhine soundcore r8169 mii uinput tcp_westwood ata_generic pata_acpi
pata_via sata_via [last unloaded: scsi_wait_scan]
[ 1392.016389] Pid: 0, comm: swapper Not tainted 3.1.6-1.fc16.i686.PAE #1
[ 1392.016396] Call Trace:
[ 1392.016411]  [<c045b4a2>] warn_slowpath_common+0x72/0xa0
[ 1392.016421]  [<c0850c46>] ? dev_watchdog+0x1d6/0x1e0
[ 1392.016430]  [<c0850c46>] ? dev_watchdog+0x1d6/0x1e0
[ 1392.016439]  [<c045b573>] warn_slowpath_fmt+0x33/0x40
[ 1392.016448]  [<c0850c46>] dev_watchdog+0x1d6/0x1e0
[ 1392.016483]  [<c0461ef0>] ? __tasklet_hi_schedule_first+0x80/0x80
[ 1392.016497]  [<c0469d86>] run_timer_softirq+0xf6/0x2e0
[ 1392.016512]  [<c04c1136>] ? rcu_start_gp+0x166/0x250
[ 1392.016521]  [<c0850a70>] ? qdisc_reset+0x40/0x40
[ 1392.016531]  [<c0461ef0>] ? __tasklet_hi_schedule_first+0x80/0x80
[ 1392.016541]  [<c0461f81>] __do_softirq+0x91/0x1c0
[ 1392.016551]  [<c0461ef0>] ? __tasklet_hi_schedule_first+0x80/0x80
[ 1392.016557]  <IRQ>  [<c04622de>] ? irq_exit+0x7e/0xa0
[ 1392.016578]  [<c041393b>] ? do_IRQ+0x4b/0xc0
[ 1392.016589]  [<c0417de8>] ? sched_clock+0x8/0x10
[ 1392.016604]  [<c048058b>] ? sched_clock_local+0xcb/0x1c0
[ 1392.016617]  [<c0931a70>] ? common_interrupt+0x30/0x38
[ 1392.016630]  [<c06c6748>] ? arch_local_irq_enable+0x5/0xb
[ 1392.016639]  [<c06c7390>] ? acpi_idle_enter_simple+0x105/0x13d
[ 1392.016649]  [<c06c7100>] ? acpi_idle_enter_bm+0xd5/0x260
[ 1392.016665]  [<c0803d6e>] ? cpuidle_idle_call+0x9e/0x230
[ 1392.016675]  [<c0410ef7>] ? cpu_idle+0x97/0xe0
[ 1392.016688]  [<c0909355>] ? rest_init+0x5d/0x68
[ 1392.016704]  [<c0bec798>] ? start_kernel+0x352/0x358
[ 1392.016713]  [<c0bec1d7>] ? loglevel+0x2b/0x2b
[ 1392.016723]  [<c0bec0ba>] ? i386_start_kernel+0xa9/0xaf
[ 1392.016730] ---[ end trace ee6262c2225576ab ]---

lspci -v
00:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
	Subsystem: Realtek Semiconductor Co., Ltd. RTL8169/8110 Family PCI Gigabit Ethernet NIC
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (8000ns min, 16000ns max), Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 16
	Region 0: I/O ports at f200 [size=256]
	Region 1: Memory at fdfff000 (32-bit, non-prefetchable) [size=256]
	[virtual] Expansion ROM at 3ef00000 [disabled] [size=64K]
	Kernel driver in use: r8169
	Kernel modules: r8169


ethtool eth0
Settings for eth0:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Half 1000baseT/Full 
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Half 1000baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	                                     1000baseT/Full 
	Link partner advertised pause frame use: Symmetric Receive-only
	Link partner advertised auto-negotiation: Yes
	Speed: 1000Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 0
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000033 (51)
			       drv probe ifdown ifup
	Link detected: yes


dmidecdode cpu:
Handle 0x0004, DMI type 4, 35 bytes
Processor Information
	Socket Designation: Socket 370
	Type: Central Processor
	Family: Other
	Manufacturer: VIA
	ID: A9 06 00 00 FF BB C9 A7
	Version: VIA C7-D
	Voltage: 1.0 V
	External Clock: 100 MHz
	Max Speed: 1500 MHz
	Current Speed: 1500 MHz
	Status: Populated, Enabled
	Upgrade: ZIF Socket
	L1 Cache Handle: 0x0008
	L2 Cache Handle: 0x0009
	L3 Cache Handle: Not Provided
	Serial Number:  
	Asset Tag:  
	Part Number:
Comment 1 Dave Jones 2011-12-28 09:54:41 EST

*** This bug has been marked as a duplicate of bug 715137 ***