Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 77118

Summary: After install and running up2date, the /var/lib/rpm/Packages file is now claimed to be in an unexpected file type
Product: [Retired] Red Hat Linux Reporter: Michael Sinz <msinz>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-01 07:53:51 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Michael Sinz 2002-11-01 07:53:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.1b) Gecko/20020813

Description of problem:
After the base install I did an up2date.  Everything worked as expected.

Today, I tried running up2date and it failed.  Running rpm with --rebuilddb
option shows the following error:

rpmdb: /var/lib/rpm/Packages: unexpected file type or format
error: cannot open Packages index

I do not know how to recover and would prefer not to need to reinstall the
system again.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

I have not spent the time trying to reproduce as I was working on getting a disk
ready for some of my work projects.

The one other item is that I do have XFS kernel installed since I am doing
things with XFS.

I am currently stuck as I can not load my RPMs on the system, which is part of
what I am testing right now.
Comment 1 Jeff Johnson 2002-11-01 09:16:20 EST
If the file type of Packages has changed, you should
look carefully at your disk parameters. It's very unlikely
that this happened through program usage, much more likely
that you have file system or disk corruption.