Bug 771579

Summary: logind fails if /dev/tty0 doesn't exist
Product: [Fedora] Fedora Reporter: Dan Horák <dan>
Component: systemdAssignee: systemd-maint
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: johannbg, lpoetter, metherid, notting, plautrba, systemd-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: systemd-37-6.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-11 12:33:24 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dan Horák 2012-01-04 03:13:34 EST
Description of problem:
logind fails if /dev/tty0 doesn't exist causing delays when user logs in. It waits until some time-out is reached in dbus. It affects Xen, s390(x) and I suppose also embedded platforms.

Version-Release number of selected component (if applicable):
systemd-37-3.fc16 (was fixed in trunk few hours ago)

Additional info and patch:
http://lists.freedesktop.org/archives/systemd-devel/2011-December/004138.html
http://lists.freedesktop.org/archives/systemd-devel/2011-December/004095.html
https://bugzilla.novell.com/show_bug.cgi?id=735047
http://cgit.freedesktop.org/systemd/commit/src/login/logind.c?id=addedec48ba0ffc4472ef6d3b5a45c9d4239f1cd