Bug 772271

Summary: [abrt] kernel: WARNING: at fs/sysfs/dir.c:455 sysfs_add_one+0xc1/0xf0()
Product: [Fedora] Fedora Reporter: Emmanuel Pacaud <emmanuel>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:8c0033bec4c2b89a516259d7189ae17f0fc619dd
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-14 12:07:40 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Emmanuel Pacaud 2012-01-06 11:32:02 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.6-1.fc16.x86_64 root=/dev/mapper/vg_lappcp348-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_lappcp348/lv_root quiet LANG=fr_FR.UTF-8 SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 rd.lvm.lv=vg_lappcp348/lv_swap KEYTABLE=fr-latin9
kernel:         3.1.6-1.fc16.x86_64
reason:         WARNING: at fs/sysfs/dir.c:455 sysfs_add_one+0xc1/0xf0()
time:           ven. 06 janv. 2012 17:29:20 CET

backtrace:
:WARNING: at fs/sysfs/dir.c:455 sysfs_add_one+0xc1/0xf0()
:Hardware name: Latitude E4300                  
:sysfs: cannot create duplicate filename '/devices/virtual/block/dm-4/slaves/mmcblk0'
:Modules linked in: vfat fat mmc_block ppdev parport_pc lp parport fuse nfs fscache auth_rpcgss nfs_acl lockd snd_hda_codec_hdmi snd_hda_codec_idt snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc uvcvideo videodev media v4l2_compat_ioctl32 arc4 dell_laptop iwlwifi mac80211 cfg80211 rfkill iTCO_wdt iTCO_vendor_support e1000e dcdbas dell_wmi i2c_i801 joydev sparse_keymap microcode uinput binfmt_misc sunrpc sdhci_pci sdhci mmc_core firewire_ohci firewire_core crc_itu_t wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 2403, comm: kpartx Tainted: G        W   3.1.6-1.fc16.x86_64 #1
:Call Trace:
: [<ffffffff8106b73f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8106b836>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff811e2411>] sysfs_add_one+0xc1/0xf0
: [<ffffffff811e2dc5>] sysfs_do_create_link+0x135/0x220
: [<ffffffff811a7df2>] ? blkdev_get+0x292/0x300
: [<ffffffff8115e5bc>] ? kmem_cache_alloc_trace+0x10c/0x140
: [<ffffffff811e2ec3>] sysfs_create_link+0x13/0x20
: [<ffffffff811a682e>] bd_link_disk_holder+0xfe/0x1e0
: [<ffffffff8146b5d9>] open_dev+0x59/0x90
: [<ffffffff8146b877>] dm_get_device+0x177/0x1e0
: [<ffffffff8146d190>] linear_ctr+0x90/0x140
: [<ffffffff8146bda1>] dm_table_add_target+0x141/0x330
: [<ffffffff8146ec84>] table_load+0xe4/0x2f0
: [<ffffffff8146ff9a>] ctl_ioctl+0x15a/0x2c0
: [<ffffffff8146eba0>] ? list_devices+0x190/0x190
: [<ffffffff81470113>] dm_ctl_ioctl+0x13/0x20
: [<ffffffff811842a8>] do_vfs_ioctl+0x98/0x550
: [<ffffffff811847f1>] sys_ioctl+0x91/0xa0
: [<ffffffff815dccc2>] system_call_fastpath+0x16/0x1b

comment:
:This crash happened while I was using a script from the pandaboard project.
:
:http://omappedia.org/wiki/Minimal-FS_SD_Configuration
:http://git.openembedded.org/openembedded/tree/contrib/angstrom/omap3-mkcard.sh

smolt_data:
:
:
:Général
:=================================
:UUID: 33d8dcc2-513c-470e-9aaa-254e5457c1fb
:SE: Fedora release 16 (Verne)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_FR.utf8
:Plateforme: x86_64
:BogoMIPS: 4786.83
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM)2 Duo CPU     P9400  @ 2.40GHz
:Stepping du processeur: 10
:Famille de processeur: 6
:Modèle du processeur: 23
:Nombre de processeurs: 2
:Vitesse du processeur: 2401
:Mémoire du système: 3907
:Swap du système: 5951
:Fabricant: Dell Inc.
:Système: Latitude E4300 
:Type d'ordinateur: Portable
:Noyau: 3.1.6-1.fc16.x86_64
:SELinux activé: 0
:Stratégie SELinux: targeted
:SELinux strict: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(4480:2082:4136:589) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(32902:10816:4136:589) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10544:4136:589) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10282:4136:589) pci, ahci, RAID, Mobile 82801 SATA RAID Controller
:(32902:10519:4136:589) pci, None, PCI/ISA, ICH9M-E LPC Interface Controller
:(32902:4341:4136:589) pci, e1000e, ETHERNET, 82567LM Gigabit Network Connection
:(32902:16949:32902:4385) pci, iwlwifi, NETWORK, Ultimate N WiFi Link 5300
:(32902:9288:4136:589) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10566:4136:589) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10549:4136:589) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(4480:2098:4136:589) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(32902:10553:4136:589) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4136:589) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:4136:589) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4136:589) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10818:4136:589) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:4136:589) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:4136:589) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:4136:589) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10558:4136:589) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:4136:589) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10548:4136:589) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10552:4136:589) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_lappcp348-lv_root / ext4 4096 4096 12901535 10195632 9540272 3276800 3037619 3037619
:/dev/sda2 /boot ext4 1024 1024 495844 410363 384763 128016 127746 127746
:/dev/mapper/vg_lappcp348-lv_home /home ext4 4096 4096 23924171 6456725 5241442 6078464 5578867 5578867
:
Comment 1 Dave Jones 2012-03-14 12:07:40 EDT

*** This bug has been marked as a duplicate of bug 759838 ***