Bug 773043

Summary: Review Request: glassfish-jaxb-api - JAXB API bundle for GlassFish V3
Product: [Fedora] Fedora Reporter: gil cattaneo <puntogil>
Component: Package ReviewAssignee: Alexander Kurtakov <akurtako>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: rawhideCC: akurtako, notting, package-review
Target Milestone: ---Flags: akurtako: fedora‑review+
limburgher: fedora‑cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-07 14:58:34 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Comment 1 Alexander Kurtakov 2012-01-12 05:33:52 EST
Gil, you need to block FE-NEEDSPONSOR when you're not sponsored. Also please use your full name in bugzilla.
Comment 2 Alexander Kurtakov 2012-01-12 05:57:40 EST
I'll do this one.
Comment 3 Alexander Kurtakov 2012-01-12 06:47:42 EST
Initial issues found:
1. There is manually added license file. We never do this in Fedora please drop it.
2. post/postun update_maven_depmap are not needed
3. rm -fr %{buildroot} in install iss not needed
4. rpm version is 2.2.3 but the link for the source points to 2.2.4 
5. please use the canonical URL tag not Url
6. non-standard-group Development/Libraries/Java - there is no such rpm group, probably better to use Development/Libraries
7. please use your full name in the changelog
Comment 5 gil cattaneo 2012-01-12 09:28:05 EST
> 4. rpm version is 2.2.3 but the link for the source points to 2.2.4 
 2,2.4 is the jaxb-impl version and is different from its apis
jaxb-impl require jaxb-api = 2.2.3
see http://repo1.maven.org/maven2/com/sun/xml/bind/jaxb-impl/2.2.4-1/jaxb-impl-2.2.4-1.pom
tks
Comment 7 Alexander Kurtakov 2012-01-24 08:01:43 EST
Package Review
==============

Key:
- = N/A
x = Check
! = Problem
? = Not evaluated

=== REQUIRED ITEMS ===
[!]  Rpmlint output:
glassfish-jaxb-api.noarch: W: invalid-license CDDLv1.1
The value of the License tag was not recognized.  Known values are: "AAL",
"Abstyles", "Adobe", "ADSL", "AFL", "AGPLv1", "AGPLv3", "AGPLv3 with
exceptions", "AMDPLPA", "AML", "AMPAS BSD", "APSL 2.0", "APSL 2.0+", "ARL",
"Artistic 2.0", "Artistic clarified", "ASL 1.0", "ASL 1.0+", "ASL 1.1", "ASL
1.1+", "ASL 2.0", "ASL 2.0+", "Barr", "Beerware", "BeOpen", "BitTorrent",
"Boost", "Borceux", "BSD", "BSD Protection", "BSD with advertising", "BSD with
attribution", "CATOSL", "CC0", "CeCILL", "CeCILL-B", "CeCILL-C", "CDDL",
"CNRI", "Condor", "Copyright only", "CPAL", "CPL", "Crossword", "Crystal
Stacker", "DOC", "Dotseqn", "DSDP", "dvipdfm", "ECL 1.0", "ECL 2.0", "eCos",
"EFL 2.0", "EFL 2.0+", "eGenix", "Entessa", "EPL", "ERPL", "EU Datagrid",
"EUPL 1.1", "Eurosym", "Fair", "FTL", "Giftware", "GL2PS", "Glide", "Glulxe",
"gnuplot", "GPL+", "GPL+ or Artistic", "GPL+ with exceptions", "GPLv1", "GPLv2
or Artistic", "GPLv2+ or Artistic", "GPLv2", "GPLv2 with exceptions",
"GPLv2+", "GPLv2+ with exceptions", "GPLv3", "GPLv3 with exceptions",
"GPLv3+", "GPLv3+ with exceptions", "IBM", "IJG", "ImageMagick", "iMatix",
"Imlib2", "Intel ACPI", "Interbase", "ISC", "Jabber", "JasPer", "JPython",
"Knuth", "Latex2e", "LBNL BSD", "LGPLv2", "LGPLv2 with exceptions", "LGPLv2+",
"LGPLv2+ or Artistic", "LGPLv2+ with exceptions", "LGPLv3", "LGPLv3 with
exceptions", "LGPLv3+", "LGPLv3+ with exceptions", "Lhcyr", "libtiff",
"LLGPL", "Logica", "LPL", "LPPL", "mecab-ipadic", "MirOS", "MIT", "MIT with
advertising", "mod_macro", "Motosoto", "MPLv1.0", "MPLv1.0+", "MPLv1.1",
"MPLv1.1+", "MS-PL", "MS-RL", "Naumen", "NCSA", "NetCDF", "Netscape",
"Newmat", "Newsletr", "NGPL", "Nokia", "NOSL", "Noweb", "OML", "OpenLDAP",
"OpenPBS", "OpenSSL", "OReilly", "OSL 1.0", "OSL 1.0+", "OSL 1.1", "OSL 1.1+",
"OSL 2.0", "OSL 2.0+", "OSL 2.1", "OSL 2.1+", "OSL 3.0", "OSL 3.0+", "Phorum",
"PHP", "PlainTeX", "Plexus", "PostgreSQL", "psutils", "Public Domain",
"Python", "Qhull", "QPL", "Rdisc", "RiceBSD", "Romio", "RPSL", "Rsfs", "Ruby",
"Saxpath", "SCEA", "SCRIP", "Sendmail", "Sleepycat", "SISSL", "SLIB", "SNIA",
"SPL", "TCL", "Teeworlds", "Threeparttable", "TMate", "TORQUEv1.1", "TOSL",
"TPL", "UCD", "Vim", "VNLSL", "VOSTROM", "VSL", "W3C", "Webmin", "Wsuipa",
"WTFPL", "wxWidgets", "Xerox", "xinetd", "XSkat", "YPLv1.1", "Zed", "Zend",
"zlib", "zlib with acknowledgement", "ZPLv1.0", "ZPLv1.0+", "ZPLv2.0",
"ZPLv2.0+", "ZPLv2.1", "ZPLv2.1+", "CDL", "FBSDDL", "GFDL", "IEEE", "LDPL",
"OFSFDL", "Open Publication", "Public Use", "CC-BY", "CC-BY-ND", "CC-BY-SA",
"DMTF", "DSL", "EFML", "Free Art", "GeoGratis", "Green OpenMusic", "OAL",
"AMS", "Arphic", "Baekmuk", "Bitstream Vera", "DoubleStroke", "Hershey",
"IPA", "Liberation", "Lucida", "MgOpen", "mplus", "OFL", "PTFL", "STIX",
"Utopia", "Wadalab", "XANO", "Redistributable, no modification permitted",
"Freely redistributable without restriction".
Correct value for License tag is "CDDL or GPLv2 with exceptions"

glassfish-jaxb-api.noarch: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.
That's fine.


[x]  Package is named according to the Package Naming Guidelines[1].
[x]  Spec file name must match the base package name, in the format %{name}.spec.
[x]  Package meets the Packaging Guidelines[2].
[x]  Package successfully compiles and builds into binary rpms.
[x]  Buildroot definition is not present
[x]  Package is licensed with an open-source compatible license and meets other legal requirements as defined in the legal section of Packaging Guidelines[3,4].
[x]  License field in the package spec file matches the actual license.
License type:CDDL or GPLv2 with exceptions 
Just needs to use the proper syntax for Fedora
[x]  If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package is included in %doc.
[x]  All independent sub-packages have license of their own
[x]  Spec file is legible and written in American English.
[x]  Sources used to build the package matches the upstream source, as provided in the spec URL.
MD5SUM this package    :
MD5SUM upstream package:
[x]  All build dependencies are listed in BuildRequires, except for any that are listed in the exceptions section of Packaging Guidelines[5].
[x]  Package must own all directories that it creates or must require other packages for directories it uses.
[x]  Package does not contain duplicates in %files.
[x]  File sections do not contain %defattr(-,root,root,-) unless changed with good reason
[x]  Permissions on files are set properly.
[x]  Package does NOT have a %clean section which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT). (not needed anymore)
[x]  Package consistently uses macros (no %{buildroot} and $RPM_BUILD_ROOT mixing)
[x]  Package contains code, or permissable content.
[x]  Fully versioned dependency in subpackages, if present.
[-]  Package contains a properly installed %{name}.desktop file if it is a GUI application.
[x]  Package does not own files or directories owned by other packages.
[x]  Javadoc documentation files are generated and included in -javadoc subpackage
[x]  Javadocs are placed in %{_javadocdir}/%{name} (no -%{version} symlinks)
[x]  Packages have proper BuildRequires/Requires on jpackage-utils
[x]  Javadoc subpackages have Require: jpackage-utils
[x]  Package uses %global not %define
[-]  If package uses tarball from VCS include comment how to re-create that tarball (svn export URL, git clone URL, ...)
[x]  If source tarball includes bundled jar/class files these need to be removed prior to building
[x]  All filenames in rpm packages must be valid UTF-8.
[x]  Jar files are installed to %{_javadir}/%{name}.jar (see [6] for details)
[x]  If package contains pom.xml files install it (including depmaps) even when building with ant
[x]  pom files has correct add_maven_depmap

=== Maven ===
[x]  Use %{_mavenpomdir} macro for placing pom files instead of %{_datadir}/maven2/poms
[-]  If package uses "-Dmaven.test.skip=true" explain why it was needed in a comment
[-]  If package uses custom depmap "-Dmaven.local.depmap.file=*" explain why it's needed in a comment
[x]  Package DOES NOT use %update_maven_depmap in %post/%postun
[x]  Packages DOES NOT have Requires(post) and Requires(postun) on jpackage-utils for %update_maven_depmap macro

=== Other suggestions ===
[x]  If possible use upstream build method (maven/ant/javac)
[x]  Avoid having BuildRequires on exact NVR unless necessary
[x]  Package has BuildArch: noarch (if possible)
[x]  Latest version is packaged.



=== Issues ===
1. License field should be "CDDL or GPLv2 with exception" to match https://fedoraproject.org/wiki/Packaging/LicensingGuidelines
2. Also when you change the license please bump the release and add a changelog entry.
Comment 12 Alexander Kurtakov 2012-01-25 07:34:20 EST
Looks good.

APPROVED.
Comment 13 gil cattaneo 2012-01-25 08:35:59 EST
New Package SCM Request
=======================
Package Name: glassfish-jaxb-api
Short Description: JAXB API bundle for GlassFish V3
Owners: gil
Branches: f16
InitialCC: java-sig
Comment 14 Jon Ciesla 2012-01-25 20:45:14 EST
Git done (by process-git-requests).
Comment 15 Alexander Kurtakov 2012-02-07 14:58:34 EST
Closing.
http://koji.fedoraproject.org/koji/buildinfo?buildID=296279