Bug 773271

Summary: [abrt] kernel: WARNING: at include/net/mac80211.h:3345 rate_control_send_low+0x111/0x190 [mac80211]()
Product: [Fedora] Fedora Reporter: Simon Kuhn <simonkuhn>
Component: kernelAssignee: Stanislaw Gruszka <sgruszka>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, linville, madhu.chinakonda, simonkuhn, stabone
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:25f29fbeb3a1a7acff3d56e34d0203a0c7bf675c
Fixed In Version: kernel-3.2.1-3.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-24 02:57:02 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Simon Kuhn 2012-01-11 06:18:39 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.5-2.fc16.x86_64 root=/dev/mapper/vg_x61t-lv_root ro rd.lvm.lv=vg_x61t/lv_root rd.md=0 rd.dm=0 KEYTABLE=de quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
kernel:         3.1.5-2.fc16.x86_64
reason:         WARNING: at include/net/mac80211.h:3345 rate_control_send_low+0x111/0x190 [mac80211]()
time:           Mi 04 Jan 2012 18:35:37 CET

backtrace:
:WARNING: at include/net/mac80211.h:3345 rate_control_send_low+0x111/0x190 [mac80211]()
:Hardware name: 7763WDK
:Modules linked in: rndis_host cdc_ether usbnet mii usb_storage fuse 8021q garp stp llc fcoe libfcoe libfc scsi_transport_fc scsi_tgt ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_conntrack_ipv4 nf_defrag_ipv4 ip6_tables xt_state nf_conntrack xts gf128mul dm_crypt snd_hda_codec_analog arc4 microcode snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device i2c_i801 iTCO_wdt iTCO_vendor_support iwl4965 iwl_legacy snd_pcm mac80211 thinkpad_acpi cfg80211 rfkill e1000e snd_timer snd soundcore snd_page_alloc binfmt_misc uinput sdhci_pci sdhci mmc_core yenta_socket i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 24752, comm: kworker/u:0 Not tainted 3.1.5-2.fc16.x86_64 #1
:Call Trace:
: [<ffffffff8106b6ef>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8106b74a>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa01d28b1>] rate_control_send_low+0x111/0x190 [mac80211]
: [<ffffffffa0299e16>] iwl4965_rs_get_rate+0x96/0x2e0 [iwl4965]
: [<ffffffffa01d2d26>] rate_control_get_rate+0x96/0x170 [mac80211]
: [<ffffffffa01dd1c8>] invoke_tx_handlers+0x898/0x1250 [mac80211]
: [<ffffffffa02631b8>] ? iwl_legacy_send_add_sta+0xf8/0x1c0 [iwl_legacy]
: [<ffffffffa01ddbda>] ieee80211_tx+0x5a/0xc0 [mac80211]
: [<ffffffffa01ddcea>] ieee80211_xmit+0xaa/0x1b0 [mac80211]
: [<ffffffff814b2633>] ? __alloc_skb+0x83/0x230
: [<ffffffffa01debeb>] ieee80211_tx_skb+0x5b/0x70 [mac80211]
: [<ffffffffa01c712d>] ieee80211_send_delba+0x11d/0x190 [mac80211]
: [<ffffffffa01c85f0>] ___ieee80211_stop_rx_ba_session+0x100/0x120 [mac80211]
: [<ffffffffa01c7cc8>] ? ___ieee80211_stop_tx_ba_session+0x168/0x180 [mac80211]
: [<ffffffffa01c866d>] __ieee80211_stop_rx_ba_session+0x5d/0x80 [mac80211]
: [<ffffffffa01c8101>] ? __ieee80211_stop_tx_ba_session+0x41/0x80 [mac80211]
: [<ffffffffa01c6e59>] ieee80211_sta_tear_down_BA_sessions+0x59/0x70 [mac80211]
: [<ffffffffa01caed3>] ieee80211_set_disassoc+0x113/0x280 [mac80211]
: [<ffffffffa01cb08e>] ieee80211_sta_connection_lost+0x4e/0xc0 [mac80211]
: [<ffffffffa01cd92e>] ieee80211_sta_work+0x10e/0x150 [mac80211]
: [<ffffffffa01d0c88>] ieee80211_iface_work+0x2b8/0x350 [mac80211]
: [<ffffffffa01d09d0>] ? ieee80211_teardown_sdata+0xe0/0xe0 [mac80211]
: [<ffffffff8108838d>] process_one_work+0x11d/0x470
: [<ffffffff8108978f>] worker_thread+0x15f/0x350
: [<ffffffff81089630>] ? manage_workers+0x230/0x230
: [<ffffffff8108ddbc>] kthread+0x8c/0xa0
: [<ffffffff815dad34>] kernel_thread_helper+0x4/0x10
: [<ffffffff8108dd30>] ? kthread_worker_fn+0x190/0x190
: [<ffffffff815dad30>] ? gs_change+0x13/0x13

smolt_data:
:
:
:Allgemein
:=================================
:UUID: 5da8d7e2-137f-49d0-8afe-48d96abf81de
:OS: Fedora release 16 (Verne)
:Standard-Runlevel: Unknown
:Sprache: de_DE.utf8
:Plattform: x86_64
:BogoMIPS: 3191.54
:CPU-Anbieter: GenuineIntel
:CPU-Modell: Intel(R) Core(TM)2 Duo CPU     L7500  @ 1.60GHz
:CPU-Stepping: 11
:CPU Familie: 6
:CPU-Modellnummer: 15
:Anzahl der CPUs: 2
:CPU-Geschwindigkeit: 1601
:Systemspeicher: 3881
:System-Swap: 0
:Anbieter: LENOVO
:System: 7763WDK ThinkPad X61 Tablet
:Form-Faktor: Notebook
:Kernel: 3.1.7-1.fc16.x86_64
:SELinux aktiviert: 1
:SELinux-Richtlinie: targeted
:SELinux erzwingen: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Geräte
:=================================
:(32902:10257:6058:8374) pci, None, PCI/ISA, T61
:(32902:17486:32902:17486) pci, None, MEMORY, Turbo Memory Controller
:(32902:10754:6058:8373) pci, i915, VIDEO, T61
:(32902:10755:6058:8373) pci, None, VIDEO, T61
:(32902:10303:6058:8365) pci, pcieport, PCI/PCI, ThinkPad T61
:(32902:10305:6058:8365) pci, pcieport, PCI/PCI, ThinkPad T61
:(4480:2082:6058:8392) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(32902:10315:6058:8364) pci, snd_hda_intel, MULTIMEDIA, ThinkPad T61
:(32902:4169:6058:8414) pci, None, ETHERNET, 82566MM Gigabit Network Connection
:(32902:10289:6058:8362) pci, uhci_hcd, USB, ThinkPad T61
:(32902:10302:6058:8361) pci, i801_smbus, SERIAL, ThinkPad T61
:(32902:9288:6058:8366) pci, None, PCI/PCI, ThinkPad T61
:(4480:1142:6058:8390) pci, None, PCI/CARDBUS, RL5c476 II
:(32902:16944:32902:4369) pci, iwl4965, NETWORK, Lenovo ThinkPad T61
:(32902:10288:6058:8362) pci, uhci_hcd, USB, ThinkPad T61
:(32902:10292:6058:8362) pci, uhci_hcd, USB, ThinkPad T61
:(32902:10293:6058:8362) pci, uhci_hcd, USB, ThinkPad T60
:(32902:10752:6058:8371) pci, agpgart-intel, HOST/PCI, T61
:(32902:10281:6058:8359) pci, ahci, STORAGE, ThinkPad T61
:(32902:10294:6058:8363) pci, ehci_hcd, USB, ThinkPad T61
:(32902:10298:6058:8363) pci, ehci_hcd, USB, ThinkPad T61
:
:
:Dateisysteminformationen
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_x61t-lv_root / ext4 4096 4096 5039269 3130978 3079798 1286144 1045034 1045034
:/dev/sda1 /boot ext4 1024 1024 495844 409894 384294 128016 127782 127782
:/dev/mapper/luks-b62e4478-52ae-47bf-9602-52742bcf72c9 /home ext4 4096 4096 10215766 8573442 8054505 2596864 2365803 2365803
:
Comment 1 Stanislaw Gruszka 2012-01-16 03:00:13 EST
Is this problem reproducible, if so, can you provide steps to reproduce?
Also can you provide /var/log/messages (or dmesg) showing kernel session from system start to the warning?
Comment 2 Simon Kuhn 2012-01-16 03:52:49 EST
I don't know what caused the problems, it appeared after booting up and registering with my WPA2 wifi. Every boot caused it. Now it seems to be fixed with Kernel 3.1.7.
I'll try to reproduce it later with 3.1.5.
Comment 3 Stanislaw Gruszka 2012-01-16 04:22:07 EST
Well, at the beginning I thought this is the same issue as in bug 731365, but it should be fixed also in 3.1.5-1, so I suspect this could be something different.

Unfortunately patch for bug 731365, was removed when we start to use compat wireless, starting from 3.1.5-11, so that bug showed up again (bug 771094).

That's very confusing.

> I'll try to reproduce it later with 3.1.5.

Let's wait for John apply this mac80211 fix for the latest fedora kernel with compat-wireless, than I ask you to retest that, and if the problem will be still reproducible, we will work on it.
Comment 4 John W. Linville 2012-01-16 13:09:59 EST
Sorry, didn't realize that patch had been dropped in the conversion process!
Comment 5 John W. Linville 2012-01-16 13:12:43 EST
*** Bug 772055 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-01-23 13:32:38 EST
kernel-3.2.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.2.1-3.fc16
Comment 7 Fedora Update System 2012-01-23 20:44:47 EST
Package kernel-3.2.1-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.2.1-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0876/kernel-3.2.1-3.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-01-24 02:57:02 EST
kernel-3.2.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.