Bug 773589

Summary: Screen brightness settings does not have any effect (2011 27inch iMac)
Product: [Fedora] Fedora Reporter: Andrew Walrond <andrew>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: andreas.tunek, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 722745 Environment:
Last Closed: 2012-06-01 14:14:07 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Andrew Walrond 2012-01-12 05:51:23 EST
+++ This bug was initially created as a clone of Bug #722745 +++

When you adjust the screen brightness, either in gnome or using the brightness
keys on the keyboard, the sliders change but there is no difference on the
actual brightness of the screen

HW: 2011 27 inch iMac, smolt:
http://www.smolts.org/client/show/pub_d9693c43-4ee8-4a8c-82a8-5332c6481f4d

I am using Refit to boot into Fedora.

--- Additional comment from andreas.tunek@gmail.com on 2011-08-05 13:41:12 EDT ---

Still happens in 2.6.40....
Comment 1 Andrew Walrond 2012-01-12 06:03:27 EST
This was working fine after the initial install of fc16, but stopped working after upgrades.

Writing to /proc/acpi/ doesn't work so I suspect a kernel regression. Infact the relevant acpi files are missing completely now so perhaps the kernel config is missing something?
Comment 2 Andrew Walrond 2012-01-12 06:17:22 EST
Scratch the last bit; I see it's moved to /sys. Still broken though - this has no effect:

echo 1 > /sys/class/backlight/acpi_video0/brightness
Comment 3 Dave Jones 2012-03-22 13:09:17 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 13:12:10 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Dave Jones 2012-03-22 13:21:51 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 6 Andrew Walrond 2012-03-23 06:59:35 EDT
Still broken.

Tried gnome settings and manual writing to /sys/class/backlight/acpi_video0/brightness. This value changes but brightness stays at max.

Anything I can do to help test, please shout. It's especially annoying since it worked fine with the initial install of fc16.
Comment 7 Andrew Walrond 2012-03-23 07:16:10 EDT
In fact it's worse than that. My imac now believes it has a battery and keeps hibernating after a few minutes due to critical battery. :(

I'll open a new bug for this.
Comment 8 Andreas Tunek 2012-03-23 16:37:28 EDT
Have you tested booting with the alt-key pressed in? If I do that I can change the brightness.
Comment 9 Andrew Walrond 2012-03-24 06:18:28 EDT
No I haven't tried that. Is this during rEFIt, grub.efi, kernel boot or what? Any ideas why it helps?
Comment 10 Andrew Walrond 2012-06-01 10:29:52 EDT
Fixed in Fedora 17. Yay!