Bug 77469

Summary: Significant Data-loss type issues on RHN updates
Product: [Retired] Red Hat Linux Reporter: Need Real Name <questy>
Component: up2dateAssignee: Adrian Likins <alikins>
Status: CLOSED WORKSFORME QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: gafton, mihai.ibanescu
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-15 06:09:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2002-11-07 15:54:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After initial update through RHN, rpm no longer works properly. It will hang on
most install tries.  If I install RH8:Custom:Everything, and then *NOT* RHN
update, I can function perfectly.  If I install RH8:Custom:Everything and run
RHN update, I can no longer install NVIDIA drivers, apt-get-rpm, synaptic. 
(these are the programs I've tried)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Install RH 8.0 Custom:Everything
2.  Run complete RHN update
3.  Install NVIDIA, apt-get-rpm, or synaptic  (all I tested...It has been part
of my standard load for a couple years now)

Actual Results:  System will run fine if rpm is not used.  Any attempt to use
rpm from cli :  rpm -Uvh, rpm -ivh, etc.  will result in the session hanging. 
You can CTRL-C out of the hang, but ps ax |grep rpm shows the process still
alive.  You must kill the process at this point.

Expected Results:  Package should've installed or failed via standard rpm behavior

Additional info:

I've tried this as a complete install on a P2-333 box with 256MB Ram and 20GB
disk twice, and on a Cele 550 with 128M RAM.  Reproduces...

I have a P3 650 and a P4 1.2 that I will be researching it on today.

When it hangs significantly, in some cases it causes a complete hang of the
system (no capslock or numlock).  On reboot, after recovering journals and
cleaning up, KDE3 hangs to reboot in the X load screens.At this point, the
system is unusable and requires a reload.

Comment 1 Adrian Likins 2002-11-07 23:13:41 UTC

  rm -rf /var/lib/rpm/__*

and trying again. This looks to be a rpm database related
locking bug (the __* files are essentially lock files).

Comment 2 Need Real Name 2002-11-08 05:24:37 UTC
Ok...  found and fixed problem.

Note:  If *any* program up2date is going to update is open, or even in memory, 
the rpm database (instead of not applying the update and giving an error as 
should be) will simply corrupt itself.  a quick edit of inittab to runlevel 3, 
reboot, rpm --rebuilddb, and then an up2date on a clean boot fixes the problem.

Thanks for the help.