Bug 77546

Summary: version conflict in sh-utils build requirements
Product: [Retired] Red Hat Linux Reporter: Ben Woodard <woodard>
Component: sh-utilsAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-21 17:27:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
fixes the problem none

Description Ben Woodard 2002-11-08 20:37:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
In the sh-utils spec file you call aclocal-1.6 and automake-1.6

sh-utils.spec:
    80  aclocal-1.6 -I m4
    81  automake-1.6
    82  autoconf

However the build requirements state that 1.4 is version that is necessary:

    26  BuildRequires: automake >= 1.4 pam-devel

Therefore building it on a system which doesn't have 1.6 installs doesn't work.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. make sure automake-1.6 is not installed
2. rpmbuild -bp sh-utils.spec

	

Actual Results:  + aclocal-1.6 -I m4
/var/tmp/rpm-tmp.97905: aclocal-1.6: command not found
error: Bad exit status from /var/tmp/rpm-tmp.97905 (%prep)


Expected Results:  It preps

Additional info:

Comment 1 Ben Woodard 2002-11-08 20:38:22 UTC
Created attachment 84284 [details]
fixes the problem

Comment 2 Tim Waugh 2003-01-21 17:27:17 UTC
Fixed in coreutils.