Bug 78072

Summary: [RFE] gnome-cd does not have a Bluecurve theme
Product: [Retired] Red Hat Linux Reporter: Michael Lee Yohe <michael>
Component: redhat-artworkAssignee: Alexander Larsson <alexl>
Status: CLOSED WONTFIX QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: garrett, mitr, srevivo
Target Milestone: ---Keywords: FutureFeature, GraphicArt, Triaged
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-08-27 10:57:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description Michael Lee Yohe 2002-11-18 12:43:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Most of the skinnable applications in Red Hat Linux 8 have a Bluecurve theme. 
This is not true for gnome-cd, which is a selectable option on the menu - Sound
& Video -> CD Player.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start gnome-cd
2. select Preferences
3. scroll through the theme list	

Actual Results:  Bluecurve does not appear.

Expected Results:  Bluecurve should be a selectable option.

Additional info:

$ rpm -qf `which gnome-cd`
gnome-media-2.0.0-9
Comment 1 Garrett LeSage 2003-07-31 12:39:50 EDT
Sounds like a great idea. We had discussed this one a while back; there has not
yet been time to implement even a simple one yet, however. (Although it should
not be too hard to do so.)
Comment 2 Michael Lee Yohe 2003-07-31 13:41:01 EDT
I just know that the key to an integrated environment is one that Red Hat
started in 8.0, continued in 9 - that being an environment that is cohesive in
appearance and functionality.

Hate to admit this (but it's true) - Microsoft's highly integrated environment,
built upon many years of revisions, makes a user familiar with an entirely new
application without having had to use it provided they've used another Microsoft
application.  It might seem trivial, but each Gnome application should have some
sort of tie to the other.

When a user starts up XMMS and it has the familiar Bluecurve appearance, a user
will much more likely feel comfortable exploring the features of the application
versus seeing an old Xlib based application that looks antiquated and non-intuitive.

Although I filed this bug under gnome-cd, this could refer to any application on
the menu that does not have the Bluecurve look.  For example, I'm hoping that
the other bug I filed (for a true Gnome 2 PDF viewer) will get some honest
attention before 9.1 (or X) is released.  "xpdf" looks like something that
should have retired with the disco era.
Comment 3 Garrett LeSage 2003-07-31 14:30:46 EDT
I fully understand about a cohesive look and feel across the board. I have
personally been pushing for such a thing for a number of years in the free
software community. There are no arguments with cohesiveness.

It takes a large amount of resources to implement this properly, especially if
everything is using a non-standard theme format. 

This is why skinning is a horrible idea (xmms, gnome-cd, Mozilla, etc.). Themes
can be applied across the board (GTK+, Qt, etc.) but skins are done on a
per-application basis and require a lot more work on the part of everyone,
including the users of the software. 

Because of this, more resources are needed to address the problem and it will
take a longer time to finally get things like XMMS or gnome-cd have a consistant
interface. Even with a similar looking theme (such as Bluecurve for XMMS), there
still are many differences, as XMMS certainly does not act like any other
application, even if it resembles everything else.

The technically proper solution is to actually have everything use a consistant
widget set and to adhere to a specification like the GNOME Human Interface
Guidelines (HIG).

In the case of gnome-cd, it does more-or-less use GTK+ widgets, although it does
have some non-standard themes. I think it is probably not nearly as complex as
XMMS (and especially Mozilla) to skin, so there is some hope that it may happen
sooner, especially if someone were to contribute a theme that worked well within
the Bluecurve family of themes.
Comment 4 Alexander Larsson 2004-08-27 10:57:26 EDT
gnome-cd is mostly using standard gtk+ widgets. Doing a bluecurve
theme for just the lcd area is not going to happen with current
resources. Unless someone else attaches one to this bug. I'm gonna
close this.